summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/autopep8/autopep8-0.5.ebuild')
-rw-r--r--dev-python/autopep8/autopep8-0.5.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/autopep8/autopep8-0.5.ebuild b/dev-python/autopep8/autopep8-0.5.ebuild
new file mode 100644
index 000000000000..991f919f2979
--- /dev/null
+++ b/dev-python/autopep8/autopep8-0.5.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/autopep8/autopep8-0.5.ebuild,v 1.1 2012/02/11 17:34:55 xarthisius Exp $
+
+EAPI=4
+
+PYTHON_DEPEND="*"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit distutils
+
+DESCRIPTION="Automatically formats Python code to conform to the PEP 8 style guide"
+HOMEPAGE="https://github.com/hhatto/autopep8 http://pypi.python.org/pypi/autopep8"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools"
+RDEPEND=""
+
+PYTHON_MODNAME="${PN}.py"