summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/bsddb3')
-rw-r--r--dev-python/bsddb3/ChangeLog9
-rw-r--r--dev-python/bsddb3/bsddb3-4.8.3.ebuild72
-rw-r--r--dev-python/bsddb3/files/bsddb3-4.8.3-BSDDB_TEST_PATH.patch26
3 files changed, 106 insertions, 1 deletions
diff --git a/dev-python/bsddb3/ChangeLog b/dev-python/bsddb3/ChangeLog
index 54d006330f4b..b5332544cd20 100644
--- a/dev-python/bsddb3/ChangeLog
+++ b/dev-python/bsddb3/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-python/bsddb3
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/bsddb3/ChangeLog,v 1.47 2010/01/10 18:32:49 nixnut Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/bsddb3/ChangeLog,v 1.48 2010/03/01 21:22:16 arfrever Exp $
+
+*bsddb3-4.8.3 (01 Mar 2010)
+
+ 01 Mar 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ +bsddb3-4.8.3.ebuild, +files/bsddb3-4.8.3-BSDDB_TEST_PATH.patch:
+ Version bump. Run tests in ${T}/tests-${PYTHON_ABI} directories
+ instead of /tmp/z-Berkeley_DB.
10 Jan 2010; nixnut <nixnut@gentoo.org> bsddb3-4.8.1.ebuild:
ppc stable #296027
diff --git a/dev-python/bsddb3/bsddb3-4.8.3.ebuild b/dev-python/bsddb3/bsddb3-4.8.3.ebuild
new file mode 100644
index 000000000000..a2b60f12b9fa
--- /dev/null
+++ b/dev-python/bsddb3/bsddb3-4.8.3.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/bsddb3/bsddb3-4.8.3.ebuild,v 1.1 2010/03/01 21:22:16 arfrever Exp $
+
+EAPI="2"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit db-use distutils eutils multilib
+
+DESCRIPTION="Python bindings for Berkeley DB"
+HOMEPAGE="http://www.jcea.es/programacion/pybsddb.htm http://pypi.python.org/pypi/bsddb3"
+SRC_URI="http://pypi.python.org/packages/source/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~sparc ~x86"
+IUSE=""
+# Documentation missing in >=4.8.2 tarball.
+# IUSE="doc"
+
+RDEPEND=">=sys-libs/db-4.6"
+DEPEND="${RDEPEND}"
+# doc? ( dev-python/sphinx )
+
+DOCS="TODO.txt"
+
+src_prepare() {
+ distutils_src_prepare
+
+ epatch "${FILESDIR}/${P}-BSDDB_TEST_PATH.patch"
+}
+
+src_compile() {
+ local DB_VER
+ if has_version sys-libs/db:4.8; then
+ DB_VER="4.8"
+ elif has_version sys-libs/db:4.7; then
+ DB_VER="4.7"
+ else
+ DB_VER="4.6"
+ fi
+
+ sed -i \
+ -e "s/dblib = 'db'/dblib = '$(db_libname ${DB_VER})'/" \
+ setup2.py setup3.py || die "sed failed"
+
+ distutils_src_compile \
+ "--berkeley-db=/usr" \
+ "--berkeley-db-incdir=$(db_includedir ${DB_VER})" \
+ "--berkeley-db-libdir=/usr/$(get_libdir)"
+
+# if use doc; then
+# mkdir html
+# sphinx-build docs html || die "Generation of documentation failed"
+# fi
+}
+
+src_test() {
+ tests() {
+ python_set_build_dir_symlink
+ BSDDB_TEST_PATH="${T}/tests-${PYTHON_ABI}" "$(PYTHON)" test.py
+ }
+ python_execute_function tests
+}
+
+src_install() {
+ distutils_src_install
+
+ rm -fr "${D}"usr/lib*/python*/site-packages/${PN}/tests
+
+# use doc && dohtml -r html/*
+}
diff --git a/dev-python/bsddb3/files/bsddb3-4.8.3-BSDDB_TEST_PATH.patch b/dev-python/bsddb3/files/bsddb3-4.8.3-BSDDB_TEST_PATH.patch
new file mode 100644
index 000000000000..b4b6ee633b7b
--- /dev/null
+++ b/dev-python/bsddb3/files/bsddb3-4.8.3-BSDDB_TEST_PATH.patch
@@ -0,0 +1,26 @@
+--- Lib/bsddb/test/test_all.py
++++ Lib/bsddb/test/test_all.py
+@@ -528,7 +528,9 @@
+
+ # This path can be overriden via "set_test_path_prefix()".
+ import os, os.path
+-get_new_path.prefix=os.path.join(os.sep,"tmp","z-Berkeley_DB")
++get_new_path.prefix=os.environ.get("BSDDB_TEST_PATH")
++if get_new_path.prefix is None:
++ get_new_path.prefix=os.path.join(os.sep,"tmp","z-Berkeley_DB")
+ get_new_path.num=0
+
+ def get_test_path_prefix() :
+--- Lib3/bsddb/test/test_all.py
++++ Lib3/bsddb/test/test_all.py
+@@ -528,7 +528,9 @@
+
+ # This path can be overriden via "set_test_path_prefix()".
+ import os, os.path
+-get_new_path.prefix=os.path.join(os.sep,"tmp","z-Berkeley_DB")
++get_new_path.prefix=os.environ.get("BSDDB_TEST_PATH")
++if get_new_path.prefix is None:
++ get_new_path.prefix=os.path.join(os.sep,"tmp","z-Berkeley_DB")
+ get_new_path.num=0
+
+ def get_test_path_prefix() :