summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/cherrypy/cherrypy-3.0.0.ebuild')
-rw-r--r--dev-python/cherrypy/cherrypy-3.0.0.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/cherrypy/cherrypy-3.0.0.ebuild b/dev-python/cherrypy/cherrypy-3.0.0.ebuild
new file mode 100644
index 000000000000..d84af5a14abb
--- /dev/null
+++ b/dev-python/cherrypy/cherrypy-3.0.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/cherrypy/cherrypy-3.0.0.ebuild,v 1.1 2006/12/27 02:20:22 dev-zero Exp $
+
+inherit distutils
+
+MY_P=CherryPy-${PV}
+
+DESCRIPTION="CherryPy is a pythonic, object-oriented web development framework."
+SRC_URI="http://download.cherrypy.org/cherrypy/${PV}/${MY_P}.tar.gz"
+HOMEPAGE="http://www.cherrypy.org/"
+IUSE=""
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~x86"
+LICENSE="BSD"
+
+DEPEND=""
+RDEPEND=""
+
+S=${WORKDIR}/${MY_P}
+
+src_test() {
+ cd cherrypy/test
+ python test.py --dumb || die "Test failed."
+}