summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/gst-python')
-rw-r--r--dev-python/gst-python/ChangeLog11
-rw-r--r--dev-python/gst-python/gst-python-0.10.15-r1.ebuild49
-rw-r--r--dev-python/gst-python/gst-python-0.10.16.ebuild49
-rw-r--r--dev-python/gst-python/gst-python-0.10.17.ebuild58
-rw-r--r--dev-python/gst-python/gst-python-0.10.21.ebuild (renamed from dev-python/gst-python/gst-python-0.10.18.ebuild)10
5 files changed, 15 insertions, 162 deletions
diff --git a/dev-python/gst-python/ChangeLog b/dev-python/gst-python/ChangeLog
index 61d4f887c7eb..004ec6499915 100644
--- a/dev-python/gst-python/ChangeLog
+++ b/dev-python/gst-python/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for dev-python/gst-python
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/gst-python/ChangeLog,v 1.94 2011/03/13 10:19:52 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/gst-python/ChangeLog,v 1.95 2011/04/13 12:07:31 leio Exp $
+
+*gst-python-0.10.21 (13 Apr 2011)
+
+ 13 Apr 2011; Mart Raudsepp <leio@gentoo.org>
+ -gst-python-0.10.15-r1.ebuild, -gst-python-0.10.16.ebuild,
+ -gst-python-0.10.17.ebuild, -gst-python-0.10.18.ebuild,
+ +gst-python-0.10.21.ebuild:
+ Version bump. gstreamer core/base 0.10.32 API additions, fixed
+ GstDiscoverer methods
13 Mar 2011; Kacper Kowalik <xarthisius@gentoo.org>
gst-python-0.10.20.ebuild:
diff --git a/dev-python/gst-python/gst-python-0.10.15-r1.ebuild b/dev-python/gst-python/gst-python-0.10.15-r1.ebuild
deleted file mode 100644
index 6c40834d85c8..000000000000
--- a/dev-python/gst-python/gst-python-0.10.15-r1.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/gst-python/gst-python-0.10.15-r1.ebuild,v 1.15 2010/07/06 18:35:40 arfrever Exp $
-
-EAPI=2
-PYTHON_DEPEND="2"
-inherit autotools eutils multilib python
-
-DESCRIPTION="A Python Interface to GStreamer"
-HOMEPAGE="http://gstreamer.freedesktop.org"
-SRC_URI="http://gstreamer.freedesktop.org/src/${PN}/${P}.tar.bz2"
-
-LICENSE="LGPL-2"
-SLOT="0.10"
-KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 sparc x86 ~x86-fbsd"
-IUSE="examples"
-
-RDEPEND="|| ( >=dev-python/pygobject-2.11.2 >=dev-python/pygtk-2.6.3 )
- >=media-libs/gstreamer-0.10.23
- >=media-libs/gst-plugins-base-0.10.23
- dev-libs/libxml2"
-DEPEND="${RDEPEND}
- dev-util/pkgconfig"
-
-src_prepare() {
- epatch "${FILESDIR}"/${PN}-0.10.9-lazy.patch
- rm -f py-compile ltmain.sh common/m4/{libtool,lt*}.m4 || die "rm -f failed"
- ln -s $(type -P true) py-compile
- AT_M4DIR="common/m4" eautoreconf
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
- dodoc AUTHORS ChangeLog NEWS README TODO
-
- if use examples; then
- docinto examples
- dodoc examples/*
- fi
-}
-
-pkg_postinst() {
- python_need_rebuild
- python_mod_optimize $(python_get_sitedir)/{pygst.py,gst-0.10}
-}
-
-pkg_postrm() {
- python_mod_cleanup $(python_get_sitedir)/{pygst.py,gst-0.10}
-}
diff --git a/dev-python/gst-python/gst-python-0.10.16.ebuild b/dev-python/gst-python/gst-python-0.10.16.ebuild
deleted file mode 100644
index 6386b5e03610..000000000000
--- a/dev-python/gst-python/gst-python-0.10.16.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/gst-python/gst-python-0.10.16.ebuild,v 1.13 2010/07/06 18:35:40 arfrever Exp $
-
-EAPI=2
-PYTHON_DEPEND="2"
-inherit autotools eutils multilib python
-
-DESCRIPTION="A Python Interface to GStreamer"
-HOMEPAGE="http://gstreamer.freedesktop.org"
-SRC_URI="http://gstreamer.freedesktop.org/src/${PN}/${P}.tar.bz2"
-
-LICENSE="LGPL-2"
-SLOT="0.10"
-KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 sparc x86 ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~x86-solaris"
-IUSE="examples"
-
-RDEPEND="|| ( >=dev-python/pygobject-2.11.2 >=dev-python/pygtk-2.6.3 )
- >=media-libs/gstreamer-0.10.24
- >=media-libs/gst-plugins-base-0.10.24
- dev-libs/libxml2"
-DEPEND="${RDEPEND}
- dev-util/pkgconfig"
-
-src_prepare() {
- epatch "${FILESDIR}"/${PN}-0.10.9-lazy.patch
- rm -f py-compile ltmain.sh common/m4/{libtool,lt*}.m4 || die "rm -f failed"
- ln -s $(type -P true) py-compile
- AT_M4DIR="common/m4" eautoreconf
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
- dodoc AUTHORS ChangeLog NEWS README TODO
-
- if use examples; then
- docinto examples
- dodoc examples/*
- fi
-}
-
-pkg_postinst() {
- python_need_rebuild
- python_mod_optimize $(python_get_sitedir)/{pygst.py,gst-0.10}
-}
-
-pkg_postrm() {
- python_mod_cleanup $(python_get_sitedir)/{pygst.py,gst-0.10}
-}
diff --git a/dev-python/gst-python/gst-python-0.10.17.ebuild b/dev-python/gst-python/gst-python-0.10.17.ebuild
deleted file mode 100644
index 31a53052f57d..000000000000
--- a/dev-python/gst-python/gst-python-0.10.17.ebuild
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/gst-python/gst-python-0.10.17.ebuild,v 1.10 2011/03/01 15:11:00 jer Exp $
-
-EAPI=2
-PYTHON_DEPEND="2"
-inherit autotools eutils multilib python
-
-DESCRIPTION="A Python Interface to GStreamer"
-HOMEPAGE="http://gstreamer.freedesktop.org"
-SRC_URI="http://gstreamer.freedesktop.org/src/${PN}/${P}.tar.bz2"
-
-LICENSE="LGPL-2"
-SLOT="0.10"
-KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 sparc x86 ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~x86-solaris"
-IUSE="examples test"
-
-RDEPEND="|| ( >=dev-python/pygobject-2.11.2 >=dev-python/pygtk-2.6.3 )
- >=media-libs/gstreamer-0.10.25
- >=media-libs/gst-plugins-base-0.10.25
- dev-libs/libxml2"
-DEPEND="${RDEPEND}
- dev-util/pkgconfig
- test? (
- media-plugins/gst-plugins-ogg
- media-plugins/gst-plugins-vorbis
- )" # tests a "audiotestsrc ! vorbisenc ! oggmux ! fakesink" pipeline
-
-src_prepare() {
- epatch "${FILESDIR}"/${PN}-0.10.9-lazy.patch
- rm -f py-compile ltmain.sh common/m4/{libtool,lt*}.m4 || die "rm -f failed"
- ln -s $(type -P true) py-compile
- AT_M4DIR="common/m4" eautoreconf
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
- dodoc AUTHORS ChangeLog NEWS README TODO
-
- if use examples; then
- docinto examples
- dodoc examples/*
- fi
-}
-
-src_test() {
- export LC_ALL="C"
- emake check || die "make check failed"
-}
-
-pkg_postinst() {
- python_need_rebuild
- python_mod_optimize $(python_get_sitedir)/{pygst.py,gst-0.10}
-}
-
-pkg_postrm() {
- python_mod_cleanup $(python_get_sitedir)/{pygst.py,gst-0.10}
-}
diff --git a/dev-python/gst-python/gst-python-0.10.18.ebuild b/dev-python/gst-python/gst-python-0.10.21.ebuild
index 5b614544dcf2..ac9d670e6d92 100644
--- a/dev-python/gst-python/gst-python-0.10.18.ebuild
+++ b/dev-python/gst-python/gst-python-0.10.21.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/gst-python/gst-python-0.10.18.ebuild,v 1.3 2010/06/13 18:37:37 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/gst-python/gst-python-0.10.21.ebuild,v 1.1 2011/04/13 12:07:31 leio Exp $
EAPI=3
PYTHON_DEPEND="2"
@@ -15,12 +15,12 @@ SRC_URI="http://gstreamer.freedesktop.org/src/${PN}/${P}.tar.bz2"
LICENSE="LGPL-2"
SLOT="0.10"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~x86-solaris"
+KEYWORDS="~alpha ~amd64 ~amd64-linux ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-interix ~x86-linux ~x86-solaris"
IUSE="examples test"
RDEPEND="|| ( >=dev-python/pygobject-2.11.2 >=dev-python/pygtk-2.6.3 )
- >=media-libs/gstreamer-0.10.25
- >=media-libs/gst-plugins-base-0.10.25
+ >=media-libs/gstreamer-0.10.32
+ >=media-libs/gst-plugins-base-0.10.32
dev-libs/libxml2"
DEPEND="${RDEPEND}
dev-util/pkgconfig