summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/httplib2/httplib2-0.7.2.ebuild')
-rw-r--r--dev-python/httplib2/httplib2-0.7.2.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/httplib2/httplib2-0.7.2.ebuild b/dev-python/httplib2/httplib2-0.7.2.ebuild
new file mode 100644
index 000000000000..e9892eed01cc
--- /dev/null
+++ b/dev-python/httplib2/httplib2-0.7.2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/httplib2/httplib2-0.7.2.ebuild,v 1.1 2011/11/30 15:56:32 neurogeek Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit distutils
+
+DESCRIPTION="A comprehensive HTTP client library"
+HOMEPAGE="http://code.google.com/p/httplib2/ http://pypi.python.org/pypi/httplib2"
+SRC_URI="http://httplib2.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x64-macos"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+RESTRICT_PYTHON_ABIS="3.*"
+#Restrict Python 3 support until upstream
+#issue #189 is solved
+
+src_test() {
+ testing() {
+ pushd "python$(python_get_version --major)" > /dev/null
+ "$(PYTHON)" httplib2test.py
+ popd > /dev/null
+ }
+ python_execute_function testing
+}