summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pyelemental/pyelemental-1.2.0.ebuild')
-rw-r--r--dev-python/pyelemental/pyelemental-1.2.0.ebuild14
1 files changed, 10 insertions, 4 deletions
diff --git a/dev-python/pyelemental/pyelemental-1.2.0.ebuild b/dev-python/pyelemental/pyelemental-1.2.0.ebuild
index 952633a25d46..9115389bf880 100644
--- a/dev-python/pyelemental/pyelemental-1.2.0.ebuild
+++ b/dev-python/pyelemental/pyelemental-1.2.0.ebuild
@@ -1,16 +1,17 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyelemental/pyelemental-1.2.0.ebuild,v 1.5 2012/05/04 15:12:15 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyelemental/pyelemental-1.2.0.ebuild,v 1.6 2012/07/08 17:42:28 jlec Exp $
+
+EAPI=4
-EAPI="3"
PYTHON_DEPEND="2"
SUPPORT_PYTHON_ABIS="1"
RESTRICT_PYTHON_ABIS="3.* 2.7-pypy-* *-jython"
-inherit distutils
+inherit distutils eutils
DESCRIPTION="Python bindings for libelemental (sci-chemistry/gelemental)"
-HOMEPAGE="http://www.kdau.com/projects/gelemental"
+HOMEPAGE="http://freecode.com/projects/gelemental/"
SRC_URI="http://www.kdau.com/files/${P}.tar.bz2"
LICENSE="GPL-3"
@@ -24,6 +25,11 @@ DEPEND="${RDEPEND}
DOCS="AUTHORS NEWS"
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gcc-4.7.patch
+ distutils_src_prepare
+}
+
src_install() {
distutils_src_install
dohtml docs/html/*.html || die "dohtml failed"