summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pyml/pyml-0.7.11.ebuild')
-rw-r--r--dev-python/pyml/pyml-0.7.11.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/pyml/pyml-0.7.11.ebuild b/dev-python/pyml/pyml-0.7.11.ebuild
new file mode 100644
index 000000000000..b3fde070fa2c
--- /dev/null
+++ b/dev-python/pyml/pyml-0.7.11.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyml/pyml-0.7.11.ebuild,v 1.1 2012/12/06 20:32:34 bicatali Exp $
+
+EAPI=4
+
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="*-pypy-* *-jython"
+
+inherit distutils
+
+MYP=PyML-${PV}
+
+DESCRIPTION="Python machine learning package"
+HOMEPAGE="http://pyml.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${MYP}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc"
+
+RDEPEND="dev-python/numpy"
+DEPEND="${RDEPEND}
+ dev-python/setuptools"
+
+S="${WORKDIR}/${MYP}"
+
+src_test() {
+ cd data
+ testing() {
+ PYTHONPATH="$(ls -d ${S}/build-${PYTHON_ABI}/lib*)" \
+ "$(PYTHON)" -c "from PyML.demo import pyml_test; pyml_test.test('svm')" || return 1
+ }
+ python_execute_function testing
+}
+
+src_install() {
+ distutils_src_install
+ use doc && dodoc doc/tutorial.pdf && dohtml -r doc/autodoc/*
+}