summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pymountboot/pymountboot-9999.ebuild')
-rw-r--r--dev-python/pymountboot/pymountboot-9999.ebuild7
1 files changed, 6 insertions, 1 deletions
diff --git a/dev-python/pymountboot/pymountboot-9999.ebuild b/dev-python/pymountboot/pymountboot-9999.ebuild
index ceb5835430f0..29b03d69f860 100644
--- a/dev-python/pymountboot/pymountboot-9999.ebuild
+++ b/dev-python/pymountboot/pymountboot-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pymountboot/pymountboot-9999.ebuild,v 1.5 2013/09/05 18:46:31 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pymountboot/pymountboot-9999.ebuild,v 1.6 2013/09/14 23:00:16 floppym Exp $
EAPI=5
PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} pypy2_0 )
@@ -28,3 +28,8 @@ DEPEND="${RDEPEND}"
KEYWORDS=
SRC_URI=
#endif
+
+python_compile() {
+ python_is_python3 || local -x CFLAGS="${CFLAGS} -fno-strict-aliasing"
+ distutils-r1_python_compile
+}