summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pyproj/pyproj-1.9.2.ebuild')
-rw-r--r--dev-python/pyproj/pyproj-1.9.2.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/pyproj/pyproj-1.9.2.ebuild b/dev-python/pyproj/pyproj-1.9.2.ebuild
new file mode 100644
index 000000000000..143a59d7a61e
--- /dev/null
+++ b/dev-python/pyproj/pyproj-1.9.2.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyproj/pyproj-1.9.2.ebuild,v 1.1 2012/09/29 23:53:34 radhermit Exp $
+
+EAPI="4"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="*-jython 2.7-pypy-*"
+
+inherit distutils
+
+DESCRIPTION="Python interface to PROJ.4 library"
+HOMEPAGE="http://code.google.com/p/pyproj/ http://pypi.python.org/pypi/pyproj"
+SRC_URI="http://pyproj.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+PYTHON_CFLAGS=("2.* + -fno-strict-aliasing")
+
+src_install(){
+ distutils_src_install
+ use doc && dohtml -r docs/*
+}