summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pyxdg')
-rw-r--r--dev-python/pyxdg/ChangeLog9
-rw-r--r--dev-python/pyxdg/pyxdg-0.20_rc1_p20120624.ebuild33
2 files changed, 41 insertions, 1 deletions
diff --git a/dev-python/pyxdg/ChangeLog b/dev-python/pyxdg/ChangeLog
index 08bee4272eba..235fb0b3a80a 100644
--- a/dev-python/pyxdg/ChangeLog
+++ b/dev-python/pyxdg/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-python/pyxdg
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyxdg/ChangeLog,v 1.81 2012/06/20 17:55:42 marienz Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyxdg/ChangeLog,v 1.82 2012/06/24 16:01:51 ssuominen Exp $
+
+*pyxdg-0.20_rc1_p20120624 (24 Jun 2012)
+
+ 24 Jun 2012; Samuli Suominen <ssuominen@gentoo.org>
+ +pyxdg-0.20_rc1_p20120624.ebuild:
+ Use snapshot to relicense Menu.py with LGPL-2 and incorporate
+ -subprocess.patch.
20 Jun 2012; Marien Zwart <marienz@gentoo.org> pyxdg-0.20_rc1.ebuild:
Update SRC_URI again to use dev.gentoo.org instead of mirror://gentoo/ (bug
diff --git a/dev-python/pyxdg/pyxdg-0.20_rc1_p20120624.ebuild b/dev-python/pyxdg/pyxdg-0.20_rc1_p20120624.ebuild
new file mode 100644
index 000000000000..7389fd8a8ad1
--- /dev/null
+++ b/dev-python/pyxdg/pyxdg-0.20_rc1_p20120624.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyxdg/pyxdg-0.20_rc1_p20120624.ebuild,v 1.1 2012/06/24 16:01:53 ssuominen Exp $
+
+EAPI=4
+
+PYTHON_DEPEND="2:2.6 3:3.2"
+SUPPORT_PYTHON_ABIS=1
+RESTRICT_PYTHON_ABIS="2.5 3.1 *-jython 2.7-pypy-*"
+
+inherit distutils
+
+DESCRIPTION="A Python module to deal with freedesktop.org specifications"
+HOMEPAGE="http://freedesktop.org/wiki/Software/pyxdg http://cgit.freedesktop.org/xdg/pyxdg/"
+SRC_URI="http://dev.gentoo.org/~ssuominen/${P}.tar.xz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="examples"
+
+PYTHON_MODNAME=xdg
+
+DOCS="AUTHORS ChangeLog README TODO"
+
+src_install() {
+ distutils_src_install
+
+ if use examples; then
+ docinto examples
+ dodoc test/*.py
+ fi
+}