summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/ropemode/ropemode-0.1_rc2.ebuild')
-rw-r--r--dev-python/ropemode/ropemode-0.1_rc2.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/ropemode/ropemode-0.1_rc2.ebuild b/dev-python/ropemode/ropemode-0.1_rc2.ebuild
new file mode 100644
index 000000000000..fb005a86ea4d
--- /dev/null
+++ b/dev-python/ropemode/ropemode-0.1_rc2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/ropemode/ropemode-0.1_rc2.ebuild,v 1.1 2010/10/03 16:39:32 arfrever Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2:2.5"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="2.4 3.*"
+
+inherit distutils
+
+MY_P="${P/_rc/-rc}"
+
+DESCRIPTION="A helper for using rope refactoring library in IDEs"
+HOMEPAGE="http://pypi.python.org/pypi/ropemode"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-python/rope-0.9.2"
+DEPEND="${DEPEND}
+ dev-python/setuptools"
+
+S="${WORKDIR}/${MY_P}"