summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/spyder/spyder-1.1.6.ebuild')
-rw-r--r--dev-python/spyder/spyder-1.1.6.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/spyder/spyder-1.1.6.ebuild b/dev-python/spyder/spyder-1.1.6.ebuild
new file mode 100644
index 000000000000..c6fab887cad9
--- /dev/null
+++ b/dev-python/spyder/spyder-1.1.6.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/spyder/spyder-1.1.6.ebuild,v 1.1 2010/09/23 21:17:35 arfrever Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2:2.5"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="2.4 3.*"
+
+inherit distutils
+
+DESCRIPTION="Python IDE with matlab-like features"
+HOMEPAGE="http://code.google.com/p/spyderlib/ http://pypi.python.org/pypi/spyder"
+SRC_URI="http://spyderlib.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="matplotlib mayavi numpy pylint scipy"
+
+RDEPEND=">=dev-python/PyQt4-4.4[webkit]
+ >=dev-python/qscintilla-python-2.1
+ matplotlib? ( dev-python/matplotlib )
+ mayavi? ( sci-visualization/mayavi:2 )
+ numpy? ( dev-python/numpy )
+ pylint? ( dev-python/pylint )
+ scipy? ( sci-libs/scipy )"
+
+PYTHON_MODNAME="spyderlib spyderplugins"