summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/astroid/ChangeLog9
-rw-r--r--dev-python/astroid/astroid-1.3.4.ebuild44
2 files changed, 51 insertions, 2 deletions
diff --git a/dev-python/astroid/ChangeLog b/dev-python/astroid/ChangeLog
index a6e411504779..ea6d0990b24a 100644
--- a/dev-python/astroid/ChangeLog
+++ b/dev-python/astroid/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/astroid
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/astroid/ChangeLog,v 1.9 2014/12/10 07:51:39 patrick Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/astroid/ChangeLog,v 1.10 2015/01/26 16:59:12 vapier Exp $
+
+*astroid-1.3.4 (26 Jan 2015)
+
+ 26 Jan 2015; Mike Frysinger <vapier@gentoo.org> +astroid-1.3.4.ebuild:
+ Version bump.
*astroid-1.3.2 (10 Dec 2014)
diff --git a/dev-python/astroid/astroid-1.3.4.ebuild b/dev-python/astroid/astroid-1.3.4.ebuild
new file mode 100644
index 000000000000..e2d98a7438d8
--- /dev/null
+++ b/dev-python/astroid/astroid-1.3.4.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/astroid/astroid-1.3.4.ebuild,v 1.1 2015/01/26 16:59:12 vapier Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+RESTRICT="test" # False is not True ;)
+
+inherit distutils-r1
+
+DESCRIPTION="Abstract Syntax Tree for logilab packages"
+HOMEPAGE="http://bitbucket.org/logilab/astroid http://pypi.python.org/pypi/astroid"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x64-macos ~x86-macos"
+IUSE="test"
+
+# Version specified in __pkginfo__.py.
+RDEPEND=">=dev-python/logilab-common-0.60.0[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ app-arch/unzip
+ test? ( ${RDEPEND}
+ >=dev-python/pylint-1.4.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/egenix-mx-base[${PYTHON_USEDEP}]' python2_7) )"
+# Required for tests
+DISTUTILS_IN_SOURCE_BUILD=1
+
+# Restrict to test phase, required because suite fails horribly without it
+src_test() {
+ local DISTUTILS_NO_PARALLEL_BUILD=1
+ distutils-r1_src_test
+}
+
+python_test() {
+ "${PYTHON}" setup.py build
+
+ pushd build/lib > /dev/null
+ PYTHONPATH=. pytest || die "Tests fail with ${EPYTHON}"
+ popd > /dev/null
+}