summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/activesupport')
-rw-r--r--dev-ruby/activesupport/ChangeLog12
-rw-r--r--dev-ruby/activesupport/activesupport-2.3.11.ebuild38
2 files changed, 49 insertions, 1 deletions
diff --git a/dev-ruby/activesupport/ChangeLog b/dev-ruby/activesupport/ChangeLog
index 3477ea0cc41a..0ffb8f7692de 100644
--- a/dev-ruby/activesupport/ChangeLog
+++ b/dev-ruby/activesupport/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for dev-ruby/activesupport
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activesupport/ChangeLog,v 1.134 2011/02/13 21:19:11 tomka Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activesupport/ChangeLog,v 1.135 2011/02/21 20:08:48 graaff Exp $
+
+ 21 Feb 2011; Hans de Graaff <graaff@gentoo.org>
+ +activesupport-2.3.11.ebuild:
+ Version bump for Rails 2.3.11.
+
+*activesupport-2.3.11 (21 Feb 2011)
+
+ 21 Feb 2011; Hans de Graaff <graaff@gentoo.org>
+ +activesupport-2.3.11.ebuild:
+ Version bump for Rails 2.3.11.
13 Feb 2011; Thomas Kahle <tomka@gentoo.org> activesupport-3.0.3.ebuild:
keyworded ~x86 per bug 351835
diff --git a/dev-ruby/activesupport/activesupport-2.3.11.ebuild b/dev-ruby/activesupport/activesupport-2.3.11.ebuild
new file mode 100644
index 000000000000..7e36aa392729
--- /dev/null
+++ b/dev-ruby/activesupport/activesupport-2.3.11.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activesupport/activesupport-2.3.11.ebuild,v 1.1 2011/02/21 20:08:48 graaff Exp $
+
+EAPI=2
+USE_RUBY="ruby18 ree18 jruby"
+
+RUBY_FAKEGEM_TASK_TEST=""
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG README"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Utility Classes and Extension to the Standard Library"
+HOMEPAGE="http://rubyforge.org/projects/activesupport/"
+
+LICENSE="MIT"
+SLOT="2.3"
+KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/builder-2.1.2 >=dev-ruby/tzinfo-0.3.16 >=dev-ruby/i18n-0.4.1:0.4"
+
+all_ruby_prepare() {
+ # Remove the bundled packages!
+ rm -r lib/active_support/vendor/{tzinfo,builder,i18n}-* \
+ || die "failed to remove vendor packages"
+
+ # This patch removes the fallback to local vendorized gems, as
+ # well as fixing the dependencies for i18n to use the correct
+ # slot.
+ epatch "${FILESDIR}"/${PN}-2.3.9-unvendorize.patch
+
+ # don't support older mocha versions as the optional codepath
+ # breaks JRuby
+ epatch "${FILESDIR}"/${PN}-2.3.5-mocha-0.9.5.patch
+}