summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/jruby-openssl/jruby-openssl-0.6-r1.ebuild')
-rw-r--r--dev-ruby/jruby-openssl/jruby-openssl-0.6-r1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-ruby/jruby-openssl/jruby-openssl-0.6-r1.ebuild b/dev-ruby/jruby-openssl/jruby-openssl-0.6-r1.ebuild
new file mode 100644
index 000000000000..f68d8b99dd8f
--- /dev/null
+++ b/dev-ruby/jruby-openssl/jruby-openssl-0.6-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/jruby-openssl/jruby-openssl-0.6-r1.ebuild,v 1.1 2010/01/04 03:57:38 flameeyes Exp $
+
+EAPI=2
+
+USE_RUBY=jruby
+
+RUBY_FAKEGEM_TASK_DOC="redocs"
+RUBY_FAKEGEM_DOCDIR="doc"
+
+# Seems like the PKCS7 support requires the BouncyCastle JARs that are
+# shipped but somewhat fails; unfortunately, this package does not
+# provide the source files, so we cannot really rebuild this.
+RESTRICT=test
+
+RUBY_FAKEGEM_TASK_TEST=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="A Ruby SSL library that works with JRuby"
+HOMEPAGE="http://rubyforge.org/projects/jruby-extras"
+
+LICENSE="MIT || ( CPL-1.0 GPL-2 LGPL-2.1 )"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+ruby_add_bdepend doc dev-ruby/hoe
+#ruby_add_bdepend test dev-ruby/hoe