summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/mixlib-shellout')
-rw-r--r--dev-ruby/mixlib-shellout/ChangeLog8
-rw-r--r--dev-ruby/mixlib-shellout/mixlib-shellout-1.4.0.ebuild27
2 files changed, 34 insertions, 1 deletions
diff --git a/dev-ruby/mixlib-shellout/ChangeLog b/dev-ruby/mixlib-shellout/ChangeLog
index beba4c8e6ed8..4b2a71ef7ef4 100644
--- a/dev-ruby/mixlib-shellout/ChangeLog
+++ b/dev-ruby/mixlib-shellout/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/mixlib-shellout
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/mixlib-shellout/ChangeLog,v 1.8 2014/07/22 05:53:19 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/mixlib-shellout/ChangeLog,v 1.9 2014/07/22 06:04:59 graaff Exp $
+
+*mixlib-shellout-1.4.0 (22 Jul 2014)
+
+ 22 Jul 2014; Hans de Graaff <graaff@gentoo.org>
+ +mixlib-shellout-1.4.0.ebuild:
+ Version bump. Add ruby21.
22 Jul 2014; Hans de Graaff <graaff@gentoo.org>
-mixlib-shellout-1.0.0.ebuild, -mixlib-shellout-1.1.0.ebuild:
diff --git a/dev-ruby/mixlib-shellout/mixlib-shellout-1.4.0.ebuild b/dev-ruby/mixlib-shellout/mixlib-shellout-1.4.0.ebuild
new file mode 100644
index 000000000000..cd5f29c6bed6
--- /dev/null
+++ b/dev-ruby/mixlib-shellout/mixlib-shellout-1.4.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/mixlib-shellout/mixlib-shellout-1.4.0.ebuild,v 1.1 2014/07/22 06:04:59 graaff Exp $
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+
+RUBY_FAKEGEM_EXTRA_DOC="README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Run external commands on Unix or Windows"
+HOMEPAGE="http://github.com/opscode/mixlib-shellout"
+SRC_URI="https://github.com/opscode/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+each_ruby_prepare() {
+ # Make sure we actually use the right interpreter for testing
+ sed -i -e "/ruby_eval/ s:ruby :${RUBY} :" spec/mixlib/shellout_spec.rb || die
+}