summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/mod_ruby/mod_ruby-1.2.4-r2.ebuild')
-rw-r--r--dev-ruby/mod_ruby/mod_ruby-1.2.4-r2.ebuild32
1 files changed, 16 insertions, 16 deletions
diff --git a/dev-ruby/mod_ruby/mod_ruby-1.2.4-r2.ebuild b/dev-ruby/mod_ruby/mod_ruby-1.2.4-r2.ebuild
index b5cfbb5055f2..cc83e70e8ea7 100644
--- a/dev-ruby/mod_ruby/mod_ruby-1.2.4-r2.ebuild
+++ b/dev-ruby/mod_ruby/mod_ruby-1.2.4-r2.ebuild
@@ -1,49 +1,49 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/mod_ruby/mod_ruby-1.2.4-r2.ebuild,v 1.10 2006/10/20 19:18:37 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/mod_ruby/mod_ruby-1.2.4-r2.ebuild,v 1.11 2007/01/15 20:09:22 chtekk Exp $
inherit apache-module
-DESCRIPTION="Embeds the Ruby interpreter into Apache"
+KEYWORDS="alpha amd64 ia64 ppc ppc64 ~sparc x86"
+
+DESCRIPTION="Embeds the Ruby interpreter into Apache."
HOMEPAGE="http://modruby.net/"
SRC_URI="http://modruby.net/archive/${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
-KEYWORDS="alpha amd64 ia64 ppc ppc64 ~sparc x86"
IUSE="doc"
-DEPEND="virtual/ruby
- doc? ( dev-ruby/rdtool )"
RDEPEND="virtual/ruby"
+DEPEND="${RDEPEND}
+ doc? ( dev-ruby/rdtool )"
-APACHE1_MOD_CONF="mod_ruby"
+APACHE1_MOD_CONF="21_mod_ruby"
APACHE2_MOD_CONF="21_mod_ruby"
APACHE1_MOD_DEFINE="RUBY"
APACHE2_MOD_DEFINE="RUBY"
APACHE1_MOD_FILE="${PN}.so"
APACHE2_MOD_FILE="${PN}.so"
-DOCFILES="ChangeLog COPYING README.* doc/*.html doc/*.css"
+
+DOCFILES="ChangeLog COPYING README.*"
need_apache
src_compile() {
- use apache2 || ./configure.rb --with-apxs=${APXS1}
use apache2 && ./configure.rb --with-apxs=${APXS2}
+ use apache2 || ./configure.rb --with-apxs=${APXS1}
- ./configure.rb --with-apxs=${APXS}
-
- emake || die "make failed"
+ emake || die "emake failed"
- if use doc; then
+ if use doc ; then
cd doc
- emake || die "make failed"
+ emake || die "emake doc failed"
fi
}
src_install() {
- emake DESTDIR=${D} install || die "make install failed"
+ emake DESTDIR="${D}" install || die "emake install failed"
- if use doc; then
+ if use doc ; then
dohtml doc/*.css doc/*.html
fi