summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/test-unit/test-unit-2.2.0.ebuild')
-rw-r--r--dev-ruby/test-unit/test-unit-2.2.0.ebuild44
1 files changed, 0 insertions, 44 deletions
diff --git a/dev-ruby/test-unit/test-unit-2.2.0.ebuild b/dev-ruby/test-unit/test-unit-2.2.0.ebuild
deleted file mode 100644
index 4b09e2e9b7c9..000000000000
--- a/dev-ruby/test-unit/test-unit-2.2.0.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/test-unit/test-unit-2.2.0.ebuild,v 1.1 2011/02/14 18:55:21 graaff Exp $
-
-EAPI=2
-USE_RUBY="ruby18 ruby19 ree18 jruby"
-
-RUBY_FAKEGEM_TASK_DOC="docs"
-RUBY_FAKEGEM_DOCDIR="doc"
-RUBY_FAKEGEM_EXTRADOC="TODO README.txt History.txt"
-
-# Disable default binwraps
-RUBY_FAKEGEM_BINWRAP=""
-
-inherit ruby-fakegem
-
-ruby_add_bdepend "doc? ( dev-ruby/hoe )"
-
-DESCRIPTION="An improved version of the Test::Unit framework from Ruby 1.8"
-HOMEPAGE="http://test-unit.rubyforge.org/"
-
-LICENSE="MIT"
-SLOT="2"
-KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
-IUSE=""
-
-each_ruby_test() {
- # the rake audit using dev-ruby/zentest currently fails, and we
- # just need to call the testsuite directly.
- # rake audit || die "rake audit failed"
- local rubyflags
-
- [[ $(basename ${RUBY}) == jruby ]] && rubyflags="-X+O"
-
- ${RUBY} ${rubyflags} test/run-test.rb || die "testsuite failed"
-}
-
-all_ruby_install() {
- all_fakegem_install
-
- # Create a testrb2 wrapper similarly to the rdoc2 wrapper for
- # rdoc-2* series.
- ruby_fakegem_binwrapper testrb /usr/bin/testrb-2
-}