summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/timecop/timecop-0.8.0.ebuild')
-rw-r--r--dev-ruby/timecop/timecop-0.8.0.ebuild5
1 files changed, 3 insertions, 2 deletions
diff --git a/dev-ruby/timecop/timecop-0.8.0.ebuild b/dev-ruby/timecop/timecop-0.8.0.ebuild
index ace4931504ec..6451a36fc698 100644
--- a/dev-ruby/timecop/timecop-0.8.0.ebuild
+++ b/dev-ruby/timecop/timecop-0.8.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/timecop/timecop-0.8.0.ebuild,v 1.1 2015/08/06 19:22:26 mrueg Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/timecop/timecop-0.8.0.ebuild,v 1.2 2015/08/06 22:09:06 mrueg Exp $
EAPI=5
@@ -29,8 +29,9 @@ all_ruby_prepare() {
sed -i -e '/bundler/ s:^:#:' -e '/History.rdoc/d' Rakefile test/test_helper.rb || die
sed -i -e '/rubygems/ a\gem "test-unit"' test/test_helper.rb || die
# FIXME after activesupport gained ruby22 support
- rm test/time_stack_item_test.rb || die
+ rm test/time_stack_item_test.rb || die
}
+
each_ruby_prepare() {
sed -i -e "/bin\/sh/ a\RUBY='${RUBY}'" test/run_tests.sh || die
}