summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-tcltk/tclxml')
-rw-r--r--dev-tcltk/tclxml/ChangeLog12
-rw-r--r--dev-tcltk/tclxml/tclxml-3.1-r2.ebuild76
-rw-r--r--dev-tcltk/tclxml/tclxml-3.2-r1.ebuild52
3 files changed, 138 insertions, 2 deletions
diff --git a/dev-tcltk/tclxml/ChangeLog b/dev-tcltk/tclxml/ChangeLog
index 4c14ebe92e93..81890dd590ec 100644
--- a/dev-tcltk/tclxml/ChangeLog
+++ b/dev-tcltk/tclxml/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-tcltk/tclxml
-# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/tclxml/ChangeLog,v 1.33 2009/06/08 11:18:49 mescalinum Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/tclxml/ChangeLog,v 1.34 2010/03/07 08:52:17 jlec Exp $
+
+*tclxml-3.2-r1 (07 Mar 2010)
+*tclxml-3.1-r2 (07 Mar 2010)
+
+ 07 Mar 2010; Justin Lecher (jlec) <jlec@gentoo.org> +tclxml-3.1-r2.ebuild,
+ +tclxml-3.2-r1.ebuild:
+ Respecting CC & LDFLAGS #247192, respecting multilib #288799, using new
+ phases in EAP=2/3 #295322, don't try to build subdirs which aren't present
08 Jun 2009; Federico Ferri <mescalinum@gentoo.org> -tclxml-3.1.ebuild:
old
diff --git a/dev-tcltk/tclxml/tclxml-3.1-r2.ebuild b/dev-tcltk/tclxml/tclxml-3.1-r2.ebuild
new file mode 100644
index 000000000000..c13f9aaa77c4
--- /dev/null
+++ b/dev-tcltk/tclxml/tclxml-3.1-r2.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/tclxml/tclxml-3.1-r2.ebuild,v 1.1 2010/03/07 08:52:17 jlec Exp $
+
+inherit autotools eutils
+
+DESCRIPTION="Pure Tcl implementation of an XML parser."
+HOMEPAGE="http://tclxml.sourceforge.net/"
+SRC_URI="mirror://sourceforge/tclxml/${P}.tar.gz"
+
+IUSE="debug expat threads xml"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+
+DEPEND=">=dev-lang/tcl-8.2
+ >=dev-tcltk/tcllib-1.2
+ xml? ( >=dev-libs/libxml2-2.6.9 )
+ expat? (
+ dev-libs/expat
+ virtual/libiconv )
+ !dev-tcltk/tclxml-expat"
+# test? ( dev-tcltk/tclparser )
+RESTRICT="test"
+
+MAKEOPTS="${MAKEOPTS} -j1"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${PN}-3_configure.patch
+ epatch "${FILESDIR}"/${PN}-3_include_path.patch
+ epatch "${FILESDIR}"/${P}-test.patch
+
+ eautoreconf
+}
+
+src_compile() {
+ econf ${myconf} \
+ --with-tclinclude="${EPREFIX}"/usr/include \
+ --with-tcl="${EPREFIX}"/usr/$(get_libdir) \
+ $(use_enable amd64 64bit) \
+ $(use_enable debug symbols) \
+ $(use_enable threads)
+
+ emake || die
+
+ if use xml ; then
+ cd "${S}"/libxml2
+ econf ${myconf} --with-Tclxml=.. || die
+ emake || die
+ fi
+ if use expat ; then
+ cd "${S}"/expat
+ econf ${myconf} --with-Tclxml=.. || die
+ emake || die
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ if use xml ; then
+ cd "${S}"/libxml2
+ emake DESTDIR="${D}" install || die
+ fi
+ if use expat ; then
+ cd "${S}"/expat
+ emake DESTDIR="${D}" install || die
+ fi
+
+ cd "${S}"
+ dodoc ANNOUNCE ChangeLog README RELNOTES || die
+ dohtml doc/*.html || die
+}
diff --git a/dev-tcltk/tclxml/tclxml-3.2-r1.ebuild b/dev-tcltk/tclxml/tclxml-3.2-r1.ebuild
new file mode 100644
index 000000000000..7d306d2b7562
--- /dev/null
+++ b/dev-tcltk/tclxml/tclxml-3.2-r1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/tclxml/tclxml-3.2-r1.ebuild,v 1.1 2010/03/07 08:52:17 jlec Exp $
+
+EAPI="3"
+
+inherit eutils multilib
+
+DESCRIPTION="Pure Tcl implementation of an XML parser."
+HOMEPAGE="http://tclxml.sourceforge.net/"
+SRC_URI="mirror://sourceforge/tclxml/${P}.tar.gz"
+
+IUSE="debug threads"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+
+DEPEND=">=dev-lang/tcl-8.2
+ >=dev-tcltk/tcllib-1.2
+ xml? ( >=dev-libs/libxml2-2.6.9 )
+ expat? ( dev-libs/expat )
+ !dev-tcltk/tclxml-expat
+ !dev-tcltk/tcldom"
+# test? ( dev-tcltk/tclparser )
+RDEPEND="${DEPEND}"
+
+RESTRICT="test"
+
+src_prepare() {
+ epatch "${FILESDIR}"/"${P}"-fix-implicit-declarations.patch
+}
+
+src_configure() {
+ local myconf=""
+
+ use threads && myconf="${myconf} --enable-threads"
+
+ econf ${myconf} \
+ --with-xml2-config="${EPREFIX}"/usr/bin/xml2-config \
+ --with-xslt-config="${EPREFIX}"/usr/bin/xslt-config \
+ --with-tclinclude="${EPREFIX}"/usr/include \
+ --with-tcl="${EPREFIX}"/usr/$(get_libdir) \
+ $(use_enable amd64 64bit) \
+ $(use_enable debug symbols)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ dodoc ANNOUNCE ChangeLog || die
+ dohtml doc/*.html || die
+}