summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-tex/chktex/chktex-1.6.2.ebuild')
-rw-r--r--dev-tex/chktex/chktex-1.6.2.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-tex/chktex/chktex-1.6.2.ebuild b/dev-tex/chktex/chktex-1.6.2.ebuild
new file mode 100644
index 000000000000..ac187c06775b
--- /dev/null
+++ b/dev-tex/chktex/chktex-1.6.2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-tex/chktex/chktex-1.6.2.ebuild,v 1.1 2004/08/17 23:38:16 usata Exp $
+
+DESCRIPTION="Checks latex source for common mistakes"
+HOMEPAGE="http://www.nongnu.org/chktex/"
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+# The ebuild relies on the appropriate tarball on the gentoo mirrors:
+# If not yet available, do the following:
+# - Download from ftp://ftp.dante.de/tex-archive/support/chktex.tar.gz
+# - move the tarball to /usr/portage/distfiles/chktex-1.6.2.tar.gz
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~amd64"
+IUSE="debug"
+
+DEPEND="virtual/tetex
+ dev-lang/perl
+ sys-apps/groff
+ dev-tex/latex2html"
+
+S="${WORKDIR}/${PN}"
+
+src_compile() {
+ chmod +x configure || die "change configure script permission failed"
+ econf `use_enable debug debug-info` || die
+ emake || die
+}
+
+src_install() {
+ einstall || die
+ dodoc COPYING SCOPTIONS
+}