summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-tex/latex-calendar/latex-calendar-3.1.ebuild')
-rw-r--r--dev-tex/latex-calendar/latex-calendar-3.1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-tex/latex-calendar/latex-calendar-3.1.ebuild b/dev-tex/latex-calendar/latex-calendar-3.1.ebuild
new file mode 100644
index 000000000000..b15bcd757c3b
--- /dev/null
+++ b/dev-tex/latex-calendar/latex-calendar-3.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-tex/latex-calendar/latex-calendar-3.1.ebuild,v 1.1 2003/06/09 13:11:26 satai Exp $
+
+inherit latex-package
+
+MY_P="calendar"
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="LaTeX package used to create Calendars. Very flexible and robust."
+SRC_URI="http://www.ibiblio.org/gentoo/distfiles/${P}.tar.gz"
+HOMEPAGE="ftp://ibiblio.org/pub/packages/TeX/macros/latex/contrib/supported/"
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="x86 sparc ppc"
+
+src_compile() {
+ debug-print function $FUNCNAME $*
+ cd ${S}
+ echo "Extracting from allcal.ins"
+ echo "y
+ y" | latex allcal.ins > /dev/null
+}
+
+src_install() {
+ cd ${S}
+ texi2dvi -q -c --language=latex calguide.tex &> /dev/null
+ latex-package_src_doinstall styles fonts bin dvi
+ dodoc README MANIFEST CATALOG
+ insinto /usr/share/doc/${P}/samples
+ doins bigdemo.tgz *.cfg *.tex *.cld
+}