summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-tex/latexdiff/latexdiff-0.5.ebuild')
-rw-r--r--dev-tex/latexdiff/latexdiff-0.5.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-tex/latexdiff/latexdiff-0.5.ebuild b/dev-tex/latexdiff/latexdiff-0.5.ebuild
new file mode 100644
index 000000000000..b10eb9062c6c
--- /dev/null
+++ b/dev-tex/latexdiff/latexdiff-0.5.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-tex/latexdiff/latexdiff-0.5.ebuild,v 1.1 2008/03/23 00:58:51 aballier Exp $
+
+DESCRIPTION="Compare two latex files and mark up significant differences"
+HOMEPAGE="http://www.ctan.org/tex-archive/support/latexdiff/"
+SRC_URI="mirror://gentoo/${P}.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="static"
+
+RDEPEND=">=dev-lang/perl-5.8
+ dev-perl/Algorithm-Diff"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+S=${WORKDIR}/${PN}
+
+src_test() {
+ emake test-ext || die "Tests failed!"
+}
+
+src_install() {
+ dobin latexdiff latexrevise latexdiff-vc || die "dobin failed"
+ doman latexdiff.1 latexrevise.1 latexdiff-vc.1 || die "doman failed"
+ dodoc CHANGES README latexdiff-man.pdf || die "dodoc failed"
+}