summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/intel-ocl-sdk/intel-ocl-sdk-2.0.31360.ebuild')
-rw-r--r--dev-util/intel-ocl-sdk/intel-ocl-sdk-2.0.31360.ebuild14
1 files changed, 3 insertions, 11 deletions
diff --git a/dev-util/intel-ocl-sdk/intel-ocl-sdk-2.0.31360.ebuild b/dev-util/intel-ocl-sdk/intel-ocl-sdk-2.0.31360.ebuild
index dc7ec9aea9ee..aa02d3448d62 100644
--- a/dev-util/intel-ocl-sdk/intel-ocl-sdk-2.0.31360.ebuild
+++ b/dev-util/intel-ocl-sdk/intel-ocl-sdk-2.0.31360.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/intel-ocl-sdk/intel-ocl-sdk-2.0.31360.ebuild,v 1.3 2012/10/03 19:17:05 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/intel-ocl-sdk/intel-ocl-sdk-2.0.31360.ebuild,v 1.4 2012/11/01 09:01:35 xarthisius Exp $
EAPI=4
@@ -23,7 +23,6 @@ RDEPEND="app-admin/eselect-opencl
dev-cpp/tbb
sys-process/numactl
tools? (
- dev-libs/boost:1.46
sys-devel/llvm
>=virtual/jre-1.6
)"
@@ -45,11 +44,12 @@ src_unpack() {
src_prepare() {
# Remove unnecessary and bundled stuff
rm -rf ${INTEL_CL}/{docs,version.txt,llc}
- rm -f ${INTEL_CL}/libboost*
+ rm -f ${INTEL_CL}/libboost*.so
rm -f ${INTEL_CL}/libtbb*
if ! use tools; then
rm -rf usr/bin
rm -f ${INTEL_CL}/{ioc64,ioc.jar}
+ rm -f ${INTEL_CL}/libboost*
fi
}
@@ -64,14 +64,6 @@ src_install() {
dosym libOpenCL.so.1 ${INTEL_CL}/libOpenCL.so
doins ${INTEL_CL}/*
-
- # Think of better way to do that...
- if use tools; then
- dosym /usr/$(get_libdir)/libboost_filesystem-1_46.so.1.46.1 \
- ${INTEL_CL}/libboost_filesystem.so.1.46.1
- dosym /usr/$(get_libdir)/libboost_system-1_46.so.1.46.1 \
- ${INTEL_CL}/libboost_system.so.1.46.1
- fi
}
pkg_postinst() {