summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/ltrace/ltrace-0.3.31.ebuild')
-rw-r--r--dev-util/ltrace/ltrace-0.3.31.ebuild15
1 files changed, 7 insertions, 8 deletions
diff --git a/dev-util/ltrace/ltrace-0.3.31.ebuild b/dev-util/ltrace/ltrace-0.3.31.ebuild
index 2dfe1b3beb58..81bb486ba768 100644
--- a/dev-util/ltrace/ltrace-0.3.31.ebuild
+++ b/dev-util/ltrace/ltrace-0.3.31.ebuild
@@ -1,17 +1,18 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/ltrace/ltrace-0.3.31.ebuild,v 1.3 2003/09/06 08:39:20 msterret Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/ltrace/ltrace-0.3.31.ebuild,v 1.4 2003/10/03 00:13:12 seemant Exp $
S=${WORKDIR}/${P}
DESCRIPTION="ltrace shows runtime library call information for dynamically linked executables"
-SRC_URI="http://ftp.debian.org/debian/pool/main/l/ltrace/${PN}_${PV}.tar.gz"
HOMEPAGE="http://packages.debian.org/unstable/utils/ltrace.html"
+SRC_URI="http://ftp.debian.org/debian/pool/main/l/ltrace/${PN}_${PV}.tar.gz"
SLOT="0"
LICENSE="GPL-2"
-KEYWORDS="x86 ~ppc"
+KEYWORDS="x86 ~ppc ~sparc ~alpha ~hppa ~mips arm ~amd64 ~ia64"
-DEPEND="virtual/glibc"
+DEPEND=">=sys-apps/sed-4
+ virtual/glibc"
src_compile() {
@@ -19,14 +20,12 @@ src_compile() {
# modify CFLAGS (hopefully in a more time friendly way)
mv Makefile Makefile.orig
- sed "s/ -O2 / ${CFLAGS} /" \
- Makefile.orig > Makefile || die "sed failed...new version of Makefile?"
+ sed -i "s/ -O2 / ${CFLAGS} /" Makefile
- emake all || die
+ emake all || make all || die
}
src_install() {
-
einstall || die
# documentation