summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/pkgconf')
-rw-r--r--dev-util/pkgconf/ChangeLog9
-rw-r--r--dev-util/pkgconf/metadata.xml3
-rw-r--r--dev-util/pkgconf/pkgconf-0.8.1.ebuild51
-rw-r--r--dev-util/pkgconf/pkgconf-0.8.ebuild4
-rw-r--r--dev-util/pkgconf/pkgconf-9999.ebuild8
5 files changed, 69 insertions, 6 deletions
diff --git a/dev-util/pkgconf/ChangeLog b/dev-util/pkgconf/ChangeLog
index a6196dd7ac49..ccf7887b0f68 100644
--- a/dev-util/pkgconf/ChangeLog
+++ b/dev-util/pkgconf/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-util/pkgconf
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/pkgconf/ChangeLog,v 1.25 2012/07/15 17:12:57 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/pkgconf/ChangeLog,v 1.26 2012/07/21 03:56:04 jdhore Exp $
+
+*pkgconf-0.8.1 (21 Jul 2012)
+
+ 21 Jul 2012; Jeff Horelick <jdhore@gentoo.org> +pkgconf-0.8.1.ebuild,
+ metadata.xml, pkgconf-0.8.ebuild, pkgconf-9999.ebuild:
+ Many cleanups (Fix SRC_URI, and add a strict USE flag where applicable) and
+ version bump with many compatiblity fixes.
15 Jul 2012; Raúl Porcel <armin76@gentoo.org> pkgconf-0.8.ebuild:
alpha/ia64/m68k/s390/sh/sparc stable wrt #420717
diff --git a/dev-util/pkgconf/metadata.xml b/dev-util/pkgconf/metadata.xml
index 8cef16f506e6..37e2b3c21ca1 100644
--- a/dev-util/pkgconf/metadata.xml
+++ b/dev-util/pkgconf/metadata.xml
@@ -3,6 +3,7 @@
<pkgmetadata>
<herd>dev-embedded</herd>
<use>
- <flag name='pkg-config'>Install as a replacement for dev-util/pkgconfig</flag>
+ <flag name='pkg-config'>Install as a replacement for dev-util/pkgconfig</flag>
+ <flag name='strict'>Adhere to POSIX pkg-config specification. Useful for finding uses of non-standard pkg-config invocations.</flag>
</use>
</pkgmetadata>
diff --git a/dev-util/pkgconf/pkgconf-0.8.1.ebuild b/dev-util/pkgconf/pkgconf-0.8.1.ebuild
new file mode 100644
index 000000000000..7f6a2203a251
--- /dev/null
+++ b/dev-util/pkgconf/pkgconf-0.8.1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/pkgconf/pkgconf-0.8.1.ebuild,v 1.1 2012/07/21 03:56:04 jdhore Exp $
+
+EAPI="4"
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="git://github.com/nenolod/pkgconf.git"
+ inherit autotools git-2
+else
+ #inherit autotools vcs-snapshot
+ inherit eutils
+ #SRC_URI="https://github.com/nenolod/pkgconf/tarball/${P} -> ${P}.tar.gz"
+ SRC_URI="http://nenolod.net/~nenolod/distfiles/${P}.tar.bz2"
+ KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
+fi
+
+DESCRIPTION="pkg-config compatible replacement with no dependencies other than ANSI C89"
+HOMEPAGE="https://github.com/nenolod/pkgconf"
+
+LICENSE="BSD-1"
+SLOT="0"
+IUSE="+pkg-config strict"
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ pkg-config? (
+ !dev-util/pkgconfig
+ !dev-util/pkg-config-lite
+ !dev-util/pkgconfig-openbsd[pkg-config]
+ )"
+
+src_prepare() {
+ [[ -e configure ]] || AT_M4DIR="m4" eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable strict)
+}
+
+src_compile() {
+ emake V=1
+}
+
+src_install() {
+ default
+ use pkg-config \
+ && dosym pkgconf /usr/bin/pkg-config \
+ || rm "${ED}"/usr/share/aclocal/pkg.m4 \
+ || die
+}
diff --git a/dev-util/pkgconf/pkgconf-0.8.ebuild b/dev-util/pkgconf/pkgconf-0.8.ebuild
index 79289e07edc5..f1c14087c62a 100644
--- a/dev-util/pkgconf/pkgconf-0.8.ebuild
+++ b/dev-util/pkgconf/pkgconf-0.8.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/pkgconf/pkgconf-0.8.ebuild,v 1.12 2012/07/15 17:12:57 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/pkgconf/pkgconf-0.8.ebuild,v 1.13 2012/07/21 03:56:04 jdhore Exp $
EAPI="4"
@@ -11,7 +11,7 @@ else
#inherit autotools vcs-snapshot
inherit eutils
#SRC_URI="https://github.com/nenolod/pkgconf/tarball/${P} -> ${P}.tar.gz"
- SRC_URI="http://tortois.es/~nenolod/distfiles/${P}.tar.bz2"
+ SRC_URI="http://nenolod.net/~nenolod/distfiles/${P}.tar.bz2"
KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ~ppc ppc64 s390 sh sparc x86 ~amd64-fbsd ~x86-fbsd"
fi
diff --git a/dev-util/pkgconf/pkgconf-9999.ebuild b/dev-util/pkgconf/pkgconf-9999.ebuild
index 559f114ac87b..fc84f9a9ec63 100644
--- a/dev-util/pkgconf/pkgconf-9999.ebuild
+++ b/dev-util/pkgconf/pkgconf-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/pkgconf/pkgconf-9999.ebuild,v 1.7 2012/06/11 18:08:10 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/pkgconf/pkgconf-9999.ebuild,v 1.8 2012/07/21 03:56:04 jdhore Exp $
EAPI="4"
@@ -19,7 +19,7 @@ HOMEPAGE="https://github.com/nenolod/pkgconf"
LICENSE="BSD-1"
SLOT="0"
-IUSE="+pkg-config"
+IUSE="+pkg-config strict"
DEPEND=""
RDEPEND="${DEPEND}
@@ -33,6 +33,10 @@ src_prepare() {
[[ -e configure ]] || AT_M4DIR="m4" eautoreconf
}
+src_configure() {
+ econf $(use_enable strict)
+}
+
src_compile() {
emake V=1
}