summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/pkgconfig/pkgconfig-0.15.0.ebuild')
-rw-r--r--dev-util/pkgconfig/pkgconfig-0.15.0.ebuild9
1 files changed, 5 insertions, 4 deletions
diff --git a/dev-util/pkgconfig/pkgconfig-0.15.0.ebuild b/dev-util/pkgconfig/pkgconfig-0.15.0.ebuild
index 0cedba8f5426..9f3795b7e35a 100644
--- a/dev-util/pkgconfig/pkgconfig-0.15.0.ebuild
+++ b/dev-util/pkgconfig/pkgconfig-0.15.0.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/pkgconfig/pkgconfig-0.15.0.ebuild,v 1.22 2004/10/23 07:41:23 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/pkgconfig/pkgconfig-0.15.0.ebuild,v 1.23 2005/04/07 00:49:19 dostrow Exp $
-inherit gnuconfig
+inherit gnuconfig flag-o-matic
DESCRIPTION="Package Config system that manages compile/link flags for libraries"
HOMEPAGE="http://www.freedesktop.org/software/pkgconfig/"
@@ -11,7 +11,7 @@ SRC_URI="http://www.freedesktop.org/software/pkgconfig/releases/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="x86 ppc sparc mips alpha arm hppa amd64 ia64 ppc64 s390 ppc-macos"
-IUSE=""
+IUSE="hardened"
DEPEND="virtual/libc"
@@ -19,6 +19,7 @@ src_unpack() {
unpack ${A}
cd ${S}
gnuconfig_update
+ (use ppc64 && use hardened) && replace-flags -O[2-3] -O1
}
src_install() {