summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/pkgconfig/pkgconfig-0.25.ebuild')
-rw-r--r--dev-util/pkgconfig/pkgconfig-0.25.ebuild37
1 files changed, 0 insertions, 37 deletions
diff --git a/dev-util/pkgconfig/pkgconfig-0.25.ebuild b/dev-util/pkgconfig/pkgconfig-0.25.ebuild
deleted file mode 100644
index 644f473332b6..000000000000
--- a/dev-util/pkgconfig/pkgconfig-0.25.ebuild
+++ /dev/null
@@ -1,37 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/pkgconfig/pkgconfig-0.25.ebuild,v 1.1 2010/06/17 09:29:59 ssuominen Exp $
-
-EAPI=2
-inherit flag-o-matic
-
-MY_P=pkg-config-${PV}
-
-DESCRIPTION="Package config system that manages compile/link flags"
-HOMEPAGE="http://pkgconfig.freedesktop.org/wiki/"
-SRC_URI="http://pkgconfig.freedesktop.org/releases/${MY_P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
-IUSE="elibc_FreeBSD hardened"
-
-S=${WORKDIR}/${MY_P}
-
-src_configure() {
- use ppc64 && use hardened && replace-flags -O[2-3] -O1
-
- # Force using all the requirements when linking, so that needed -pthread
- # lines are inherited between libraries
- local myconf
- use elibc_FreeBSD && myconf="--enable-indirect-deps"
-
- econf \
- --docdir=/usr/share/doc/${PF}/html \
- ${myconf}
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die
- dodoc AUTHORS ChangeLog NEWS README
-}