summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/valgrind/valgrind-1.0.0.ebuild')
-rw-r--r--dev-util/valgrind/valgrind-1.0.0.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-util/valgrind/valgrind-1.0.0.ebuild b/dev-util/valgrind/valgrind-1.0.0.ebuild
new file mode 100644
index 000000000000..b23a0667d5e1
--- /dev/null
+++ b/dev-util/valgrind/valgrind-1.0.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/dev-util/valgrind/valgrind-1.0.0.ebuild,v 1.1 2002/08/03 04:40:34 blocke Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="An open-source memory debugger for x86-GNU/Linux"
+HOMEPAGE="http://developer.kde.org/~sewardj"
+SRC_URI="http://developer.kde.org/~sewardj/${P}.tar.bz2"
+DEPEND="virtual/glibc
+ X? ( virtual/x11 )"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 -sparc -ppc -sparc64"
+
+src_compile()
+{
+ local myconf
+
+ use X && myconf="--with-x" || myconf="--with-x=no"
+
+ # note: it does not appear safe to play with CFLAGS
+ econf ${myconf} || die
+ emake || die
+}
+
+src_install()
+{
+ einstall docdir="${D}/usr/share/doc/${PF}" || die
+ dodoc README* COPYING ChangeLog TODO ACKNOWLEDGEMENTS AUTHORS NEWS
+}
+