summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/cunit/ChangeLog5
-rw-r--r--dev-util/cunit/cunit-2.1_p2.ebuild10
2 files changed, 11 insertions, 4 deletions
diff --git a/dev-util/cunit/ChangeLog b/dev-util/cunit/ChangeLog
index a0104428641d..095d4cc41124 100644
--- a/dev-util/cunit/ChangeLog
+++ b/dev-util/cunit/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-util/cunit
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/cunit/ChangeLog,v 1.37 2013/05/21 20:15:33 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cunit/ChangeLog,v 1.38 2013/10/09 19:33:31 hasufell Exp $
+
+ 09 Oct 2013; Julian Ospald <hasufell@gentoo.org> cunit-2.1_p2.ebuild:
+ add ncurses useflag
21 May 2013; Jeroen Roovers <jer@gentoo.org> cunit-2.1_p2.ebuild:
Remove ncurses support (bug #336901).
diff --git a/dev-util/cunit/cunit-2.1_p2.ebuild b/dev-util/cunit/cunit-2.1_p2.ebuild
index a6d261bafba0..daddd42fae59 100644
--- a/dev-util/cunit/cunit-2.1_p2.ebuild
+++ b/dev-util/cunit/cunit-2.1_p2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/cunit/cunit-2.1_p2.ebuild,v 1.3 2013/05/21 20:15:33 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cunit/cunit-2.1_p2.ebuild,v 1.4 2013/10/09 19:33:31 hasufell Exp $
EAPI=5
inherit autotools eutils flag-o-matic
@@ -16,7 +16,10 @@ HOMEPAGE="http://cunit.sourceforge.net"
SLOT="0"
LICENSE="LGPL-2"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~amd64-linux ~x86-linux ~ppc-macos"
-IUSE="static-libs"
+IUSE="ncurses static-libs"
+
+RDEPEND="ncurses? ( sys-libs/ncurses )"
+DEPEND="${RDEPEND}"
S=${WORKDIR}/${MY_P}
@@ -33,9 +36,10 @@ src_prepare() {
src_configure() {
econf \
+ --docdir="${EPREFIX}"/usr/share/doc/${PF} \
$(use_enable static-libs static) \
--disable-debug \
- --docdir="${EPREFIX}"/usr/share/doc/${PF}
+ $(use_enable ncurses curses)
}
src_install() {