summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-action/armagetron')
-rw-r--r--games-action/armagetron/ChangeLog7
-rw-r--r--games-action/armagetron/Manifest4
-rw-r--r--games-action/armagetron/armagetron-0.2.6.0.ebuild62
-rw-r--r--games-action/armagetron/files/digest-armagetron-0.2.6.03
4 files changed, 73 insertions, 3 deletions
diff --git a/games-action/armagetron/ChangeLog b/games-action/armagetron/ChangeLog
index 0b209d1f7837..575f8c642e02 100644
--- a/games-action/armagetron/ChangeLog
+++ b/games-action/armagetron/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-action/armagetron
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/armagetron/ChangeLog,v 1.2 2003/09/10 20:28:55 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/armagetron/ChangeLog,v 1.3 2003/10/14 22:29:47 luke-jr Exp $
+
+*armagetron-0.2.6.0 (14 Oct 2003)
+
+ 14 Oct 2003; Luke-Jr <luke-jr@gentoo.org> armagetron-0.2.6.0.ebuild:
+ Version bump
25 Aug 2003; Luke-Jr <luke-jr@gentoo.org> armagetron-0.1.4.9.ebuild,
armagetron-0.2.4-r1.ebuild, armagetron-0.2.5.1.ebuild:
diff --git a/games-action/armagetron/Manifest b/games-action/armagetron/Manifest
index 44bf1440114d..c7cb043aca4b 100644
--- a/games-action/armagetron/Manifest
+++ b/games-action/armagetron/Manifest
@@ -1,9 +1,9 @@
-MD5 aed4b8807c528ef0b8552b1f8d0a7ab4 ChangeLog 2479
+MD5 2f47b274b0996367d276858e0be842a1 ChangeLog 2602
MD5 acb5ae8f927b7bf0841dc8553f9d28cf armagetron-0.1.4.9.ebuild 2093
MD5 cab1bbf31ec3a81a6dfbb65ff145d205 armagetron-0.2.4-r1.ebuild 2122
MD5 a1860292f38d16ca477a88a2a932c537 armagetron-0.2.5.1.ebuild 2045
MD5 cb34f5e24489e69198ef24f6bb485fef metadata.xml 367
-MD5 a1860292f38d16ca477a88a2a932c537 armagetron-0.2.6.0.ebuild 2045
+MD5 a095478b51a15bbb8e0940b9d0e0a712 armagetron-0.2.6.0.ebuild 2046
MD5 b099d1ac147af025edade2ecdb5d4ba0 files/armagetron-0.1.4.9-Makefile.global.in.patch 400
MD5 778ff6fa5181b49c27da527ddf9a246f files/armagetron-0.1.4.9-configure.patch 422
MD5 f1f78fdf04c0f8cdd942f5bf1e06896a files/armagetron-0.1.4.9.sh 68
diff --git a/games-action/armagetron/armagetron-0.2.6.0.ebuild b/games-action/armagetron/armagetron-0.2.6.0.ebuild
new file mode 100644
index 000000000000..b6c20147b6cf
--- /dev/null
+++ b/games-action/armagetron/armagetron-0.2.6.0.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/armagetron/armagetron-0.2.6.0.ebuild,v 1.1 2003/10/14 22:29:47 luke-jr Exp $
+
+inherit games
+
+IUSE="`echo " ${IUSE} " | sed 's/ dedicated //'`"
+
+S=${WORKDIR}/${PN}-${PV}
+DESCRIPTION="armagetron: 3d tron lightcycles, just like the movie"
+SRC_URI="mirror://sourceforge/armagetron/${P}.tar.bz2
+ http://armagetron.sourceforge.net/addons/moviesounds_fq.zip
+ http://armagetron.sourceforge.net/addons/moviepack.zip"
+HOMEPAGE="http://armagetron.sourceforge.net/"
+KEYWORDS="~x86 ~ppc"
+LICENSE="GPL-2"
+SLOT="0"
+CXXFLAGS=${CXXFLAGS/-fno-exceptions/}
+RDEPEND="virtual/x11
+ virtual/opengl
+ media-libs/libsdl
+ media-libs/sdl-image
+ sys-libs/zlib
+ media-libs/libpng"
+
+DEPEND="$RDEPEND
+ >=sys-apps/sed-4
+ app-arch/unzip"
+
+src_unpack() {
+ unpack ${PN}-${PV}.tar.bz2
+ unpack moviesounds_fq.zip
+ unpack moviepack.zip
+ set > /tmp/emerge-env.txt
+ cd ${S}
+ # Uses $SYNC which which conflicts with emerge
+ sed -i \
+ -e 's/$(SYNC)/$(SYNCDISK)/' Makefile.global.in || \
+ die 'sed Makefile.global.in failed'
+}
+
+src_install () {
+ # make install for armagetron is non-existant
+ dodir ${GAMES_BINDIR}
+ dodir ${GAMES_LIBDIR}/${PN}
+ dodir ${GAMES_DATADIR}/${PN}
+ dodir /usr/share/fonts
+ cp src/tron/armagetron ${D}/${GAMES_LIBDIR}/${PN} || die "No Armagetron Executable"
+ cp -r arenas models sound textures language config \
+ ${D}/${GAMES_DATADIR}/${PN}/ || die "Missing ArmageTRON data"
+ # maybe convert this to a .png or something
+ #cp tron.ico ${D}/${GAMES_DATADIR}/${PN}
+ dohtml doc
+ newgamesbin ${FILESDIR}/${PN}-0.2.4-r1.sh ${PN} || die "ArmageTRON shell script not found"
+ dosed "s:DATADIR:${GAMES_DATADIR}/${PN}:" ${GAMES_BINDIR}/${PN}
+ dosed "s:BINDIR:${GAMES_LIBDIR}/${PN}:" ${GAMES_BINDIR}/${PN}
+ cp -r ../moviepack ${D}/${GAMES_DATADIR}/${PN}
+ cp -r ../moviesounds ${D}/${GAMES_DATADIR}/${PN}
+ chmod -R a+r ${D}
+ chmod a+rx ${D}/${GAMES_BINDIR}/${PN}
+ chmod a+rx ${D}/${GAMES_LIBDIR}/${PN}/${PN}
+}
diff --git a/games-action/armagetron/files/digest-armagetron-0.2.6.0 b/games-action/armagetron/files/digest-armagetron-0.2.6.0
new file mode 100644
index 000000000000..74eb40330011
--- /dev/null
+++ b/games-action/armagetron/files/digest-armagetron-0.2.6.0
@@ -0,0 +1,3 @@
+MD5 602d3f3c942e3ed06bcc2e9c7e39abf7 armagetron-0.2.6.0.tar.bz2 1048090
+MD5 3c5d04af52eb296cdeb2fba5ecbd8899 moviesounds_fq.zip 2182021
+MD5 e2d40309dde7e1339ca6aff7599cdfa3 moviepack.zip 352253