summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-action/xpilot')
-rw-r--r--games-action/xpilot/ChangeLog5
-rw-r--r--games-action/xpilot/xpilot-4.5.5.ebuild13
2 files changed, 12 insertions, 6 deletions
diff --git a/games-action/xpilot/ChangeLog b/games-action/xpilot/ChangeLog
index b1cb02cbd930..f64be48e591d 100644
--- a/games-action/xpilot/ChangeLog
+++ b/games-action/xpilot/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-action/xpilot
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/xpilot/ChangeLog,v 1.13 2015/01/02 11:54:54 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/xpilot/ChangeLog,v 1.14 2015/02/19 00:46:13 mr_bones_ Exp $
+
+ 19 Feb 2015; Michael Sterrett <mr_bones_@gentoo.org> xpilot-4.5.5.ebuild:
+ EAPI=5; build with newer glibc (bug #540306)
02 Jan 2015; Tupone Alfredo <tupone@gentoo.org> xpilot-4.5.5.ebuild:
EAPI 4
diff --git a/games-action/xpilot/xpilot-4.5.5.ebuild b/games-action/xpilot/xpilot-4.5.5.ebuild
index f6a4edc4a528..53f75e0d27b8 100644
--- a/games-action/xpilot/xpilot-4.5.5.ebuild
+++ b/games-action/xpilot/xpilot-4.5.5.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/xpilot/xpilot-4.5.5.ebuild,v 1.4 2015/01/02 11:54:54 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/xpilot/xpilot-4.5.5.ebuild,v 1.5 2015/02/19 00:46:13 mr_bones_ Exp $
-EAPI=4
+EAPI=5
inherit eutils games
DESCRIPTION="A multi-player 2D client/server space game"
@@ -28,12 +28,15 @@ src_prepare() {
-e '/^INSTMAN/s:=.*:=/usr/share/man/man6:' \
-e "/^INSTLIB/s:=.*:=${GAMES_DATADIR}/${PN}:" \
-e "/^INSTBIN/s:=.*:=${GAMES_BINDIR}:" \
- Local.config \
- || die "sed failed"
+ Local.config || die
+ # work with glibc-2.20
+ sed -i \
+ -e 's/getline/lgetline/' \
+ src/client/textinterface.c || die
}
src_compile() {
- xmkmf || die "xmkmf failed"
+ xmkmf || die
emake Makefiles
emake includes
emake depend