summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-arcade/blobby/blobby-0.9c.ebuild')
-rw-r--r--games-arcade/blobby/blobby-0.9c.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/games-arcade/blobby/blobby-0.9c.ebuild b/games-arcade/blobby/blobby-0.9c.ebuild
new file mode 100644
index 000000000000..f8221667ff0b
--- /dev/null
+++ b/games-arcade/blobby/blobby-0.9c.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/blobby/blobby-0.9c.ebuild,v 1.1 2011/11/18 16:05:15 mr_bones_ Exp $
+
+EAPI=2
+inherit cmake-utils eutils games
+
+DESCRIPTION="A beach ball game with blobs of goo"
+HOMEPAGE="http://sourceforge.net/projects/blobby/"
+SRC_URI="mirror://sourceforge/${PN}/${PN}2-linux-${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-games/physfs-2[zip]
+ media-libs/libsdl[audio,joystick,opengl,video,X]
+ virtual/opengl"
+DEPEND="${RDEPEND}
+ dev-libs/boost
+ dev-util/pkgconfig"
+
+S=${WORKDIR}/${PN}-beta-${PV}
+
+src_prepare() {
+ sed -i -e "s:share/${PN}:${GAMES_DATADIR}/${PN}:" data/CMakeLists.txt || die
+ sed -i -e "s:share/${PN}:${GAMES_DATADIR/\/usr\/}/${PN}:" src/main.cpp || die
+ sed -i -e "/DESTINATION/s:bin:${GAMES_BINDIR}:" src/CMakeLists.txt || die
+}
+
+src_configure() {
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile
+}
+
+src_install() {
+ DOCS="AUTHORS ChangeLog README TODO" cmake-utils_src_install
+
+ newicon data/Icon.bmp ${PN}.bmp
+ make_desktop_entry ${PN} "Blobby Volley" /usr/share/pixmaps/${PN}.bmp
+
+ prepgamesdirs
+}