summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-arcade/rocksndiamonds/rocksndiamonds-3.0.6.ebuild')
-rw-r--r--games-arcade/rocksndiamonds/rocksndiamonds-3.0.6.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/games-arcade/rocksndiamonds/rocksndiamonds-3.0.6.ebuild b/games-arcade/rocksndiamonds/rocksndiamonds-3.0.6.ebuild
new file mode 100644
index 000000000000..1661bc0bdfb9
--- /dev/null
+++ b/games-arcade/rocksndiamonds/rocksndiamonds-3.0.6.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/rocksndiamonds/rocksndiamonds-3.0.6.ebuild,v 1.1 2003/10/11 05:12:08 vapier Exp $
+
+inherit games flag-o-matic
+
+DESCRIPTION="A Boulderdash clone"
+HOMEPAGE="http://www.artsoft.org/rocksndiamonds/"
+SRC_URI="http://www.artsoft.org/RELEASES/unix/rocksndiamonds/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+
+DEPEND="X? ( virtual/x11 )
+ sdl? ( >=media-libs/libsdl-1.2.3
+ >=media-libs/sdl-mixer-1.2.4
+ >=media-libs/sdl-image-1.2.2 )
+ || ( X? ( ) sdl? ( ) virtual/x11 )"
+
+src_compile() {
+ replace-flags -march=k6 -march=i586
+
+ local makeopts="RO_GAME_DIR=${GAMES_DATADIR}/${PN} RW_GAME_DIR=${GAMES_STATEDIR}/${PN}"
+ if [ `use X` ] || [ -z "`use X``use sdl`" ] ; then
+ make clean || die
+ make ${makeopts} OPTIONS="${CFLAGS}" x11 || die
+ mv rocksndiamonds{,.x11}
+ fi
+ if [ `use sdl` ] ; then
+ make clean || die
+ make ${makeopts} OPTIONS="${CFLAGS}" sdl || die
+ mv rocksndiamonds{,.sdl}
+ fi
+}
+
+src_install() {
+ dogamesbin rocksndiamonds.{sdl,x11}
+ dodir ${GAMES_DATADIR}/${PN}
+ cp -R graphics levels music sounds ${D}/${GAMES_DATADIR}/${PN}/
+
+ newman rocksndiamonds.{1,6}
+ dodoc CHANGES CREDITS HARDWARE README TODO docs/elements/*.txt
+
+ prepgamesdirs
+}