summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-arcade/vor/vor-0.5.4.ebuild')
-rw-r--r--games-arcade/vor/vor-0.5.4.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/games-arcade/vor/vor-0.5.4.ebuild b/games-arcade/vor/vor-0.5.4.ebuild
new file mode 100644
index 000000000000..a82aba2e3bbb
--- /dev/null
+++ b/games-arcade/vor/vor-0.5.4.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/vor/vor-0.5.4.ebuild,v 1.1 2009/05/30 11:42:14 nyhm Exp $
+
+EAPI=2
+inherit eutils games
+
+DESCRIPTION="Variations on Rockdodger: Dodge the rocks until you die"
+HOMEPAGE="http://jasonwoof.org/vor"
+SRC_URI="http://qualdan.com/vor/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND="media-libs/libsdl
+ media-libs/sdl-image[png]
+ media-libs/sdl-mixer[mikmod]"
+
+src_compile() {
+ emake \
+ CFLAGS="${CFLAGS}" \
+ LDFLAGS="${LDFLAGS}" \
+ pkgdatadir="${GAMES_DATADIR}"/${PN} \
+ || die "emake failed"
+}
+
+src_install() {
+ dogamesbin ${PN} || die "dogamesbin failed"
+ insinto "${GAMES_DATADIR}"/${PN}
+ doins data/* || die "doins failed"
+ newicon data/icon.png ${PN}.png
+ make_desktop_entry ${PN} VoR
+ dodoc README todo
+ prepgamesdirs
+}