summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-board/xboard/files/xboard-4.5.3a-gentoo.patch')
-rw-r--r--games-board/xboard/files/xboard-4.5.3a-gentoo.patch129
1 files changed, 129 insertions, 0 deletions
diff --git a/games-board/xboard/files/xboard-4.5.3a-gentoo.patch b/games-board/xboard/files/xboard-4.5.3a-gentoo.patch
new file mode 100644
index 000000000000..56e1ba8e10eb
--- /dev/null
+++ b/games-board/xboard/files/xboard-4.5.3a-gentoo.patch
@@ -0,0 +1,129 @@
+diff -ru xboard-4.5.2a.orig/Makefile.am xboard-4.5.2a/Makefile.am
+--- xboard-4.5.2a.orig/Makefile.am 2011-05-01 23:15:52.000000000 -0400
++++ xboard-4.5.2a/Makefile.am 2011-05-06 17:24:16.268244229 -0400
+@@ -33,14 +33,10 @@
+ $(ZPY)
+ xboard_LDADD = -lm @XAW_LIBS@ @X_LIBS@
+
+-EXTRA_DIST = pixmaps bitmaps sounds winboard filebrowser/README \
+- xboard.texi gpl.texinfo texi2man texinfo.tex xboard.man xboard.desktop \
+- COPYRIGHT FAQ.html engine-intf.html ics-parsing.txt readme.htm zippy.README \
+- xboard.conf.in SHORTLOG DIFFSTAT history.c
+-
+ DISTCLEANFILES = stamp-h
+
+-AM_CPPFLAGS=-DINFODIR='"$(infodir)"' @X_CFLAGS@ -DSYSCONFDIR='"$(sysconfdir)"' -DBITMAPDIR='"$(datadir)/games/xboard/bitmaps/default"'
++bitmapsdir = $(datadir)/default
++AM_CPPFLAGS=-DINFODIR='"$(infodir)"' @X_CFLAGS@ -DSYSCONFDIR='"$(sysconfdir)"' -DBITMAPDIR='"$(bitmapsdir)"'
+
+ info_TEXINFOS = xboard.texi
+ xboard_TEXINFOS = copyright.texi
+@@ -54,21 +50,14 @@
+
+ ### icon files
+
+-icondir = $(datadir)/icons/hicolor/48x48/apps
++icondir = /usr/share/icons/hicolor/48x48/apps
+ dist_icon_DATA = xboard.png
+-svgicondir = $(datadir)/icons/hicolor/scalable/apps
++svgicondir = /usr/share/icons/hicolor/scalable/apps
+ dist_svgicon_DATA = xboard.svg
+
+
+-### desktop files for KDE and gnome
+-
+-Applicationsdir = $(datadir)/applications
+-Applications_DATA = xboard.desktop
+-
+-
+ ### directory and files for bitmaps
+
+-bitmapsdir = $(datadir)/games/xboard/bitmaps/default
+ dist_bitmaps_DATA = \
+ bitmaps/a33o.bm bitmaps/c45s.bm bitmaps/icon_outline.bm bitmaps/m49o.bm bitmaps/p45o.bm bitmaps/r29o.bm \
+ bitmaps/a33s.bm bitmaps/c49o.bm bitmaps/icon_white.bm bitmaps/m49s.bm bitmaps/p45s.bm bitmaps/r29s.bm \
+@@ -137,13 +126,13 @@
+
+ ### directory and files for pixmaps
+
+-pixmapsdir = $(datadir)/games/xboard/pixmaps/textures
++pixmapsdir = $(datadir)/pixmaps/textures
+ dist_pixmaps_DATA = pixmaps/wood_d.xpm pixmaps/wood_l.xpm
+
+
+ ### directory and files for sound files
+
+-soundsdir = $(datadir)/games/xboard/sounds
++soundsdir = $(datadir)/sounds
+ dist_sounds_DATA = \
+ sounds/cymbal.wav sounds/pop2.wav sounds/slap.wav sounds/ding1.wav sounds/laser.wav \
+ sounds/woodthunk.wav sounds/gong.wav sounds/penalty.wav sounds/honkhonk.wav sounds/phone.wav
+diff -ru xboard-4.5.2a.orig/configure.ac xboard-4.5.2a/configure.ac
+--- xboard-4.5.2a.orig/configure.ac 2011-05-01 23:17:29.000000000 -0400
++++ xboard-4.5.2a/configure.ac 2011-05-06 17:24:16.268244229 -0400
+@@ -131,32 +131,17 @@
+ exit 1
+ fi
+
+-dnl | test if user wants ot use Xaw3d or Xaw
++AC_ARG_WITH(Xaw3d,
++[ --with-Xaw3d use Xaw3d instead of Xaw],
++[ with_xaw3d="$withval"], [enable_xaw3d="no"])
+
+-dnl | add configure option for Xaw3d
+-AC_ARG_WITH([Xaw3d],
+- [AS_HELP_STRING([--with-Xaw3d],[use Xaw3d instead of Xaw])],
+- [],
+- [with_Xaw3d=no])
+-
+-dnl | check availability of Xaw3d
+-XAW_LIBS=
+-AS_IF([test x"$with_Xaw3d" != x"no"],
+- [AC_CHECK_LIB([Xaw3d],
+- [XawTextReplace],
+- [AC_SUBST([XAW_LIBS],["-lXaw3d"])
+- AC_DEFINE([USE_XAW3D], [1],
+- [Define if you want to use Xaw3d])],
+- [AC_MSG_ERROR([--with-Xaw3d was given, but test for Xaw3d failed. Make sure that you have Xaw3d installed, else you might want to try the configure option --without-Xaw3d])],
+- [-lXaw])])
+-dnl | no Xaw3d, check for Xaw
+-if test x"$with_Xaw3d" = x"no" ; then
+- AC_CHECK_HEADER(X11/Xaw/Dialog.h,xaw_headers="yes", xaw_headers="no")
+- if test x"$xaw_headers" = x"no" ; then
+- AC_MSG_ERROR([Xaw headers not found. Please install the Xaw package and headers.])
+- fi
+- XAW_LIBS="-lXaw"
++if test "$withval" = yes; then
++ AC_DEFINE(USE_XAW3D)
++ XAW_LIBS="-lXaw3d"
++else
++ XAW_LIBS="-lXaw"
+ fi
++
+ AC_SUBST(XAW_LIBS)
+
+ dnl | end Xaw/Xaw3d test
+diff -ru xboard-4.5.2a.orig/xboard.conf.in xboard-4.5.2a/xboard.conf.in
+--- xboard-4.5.2a.orig/xboard.conf.in 2011-05-01 23:15:52.000000000 -0400
++++ xboard-4.5.2a/xboard.conf.in 2011-05-06 17:24:29.271622485 -0400
+@@ -57,7 +57,7 @@
+ ;
+ ; Engines & adjudicatons in engine-engine games
+ ;
+--firstChessProgram fairymax
++-firstChessProgram gnuchess
+ -secondChessProgram fairymax
+ -niceEngines 0
+ -polyglotDir ""
+diff -ru xboard-4.5.2a.orig/xboard.h xboard-4.5.2a/xboard.h
+--- xboard-4.5.2a.orig/xboard.h 2011-05-01 23:15:52.000000000 -0400
++++ xboard-4.5.2a/xboard.h 2011-05-06 17:24:16.268244229 -0400
+@@ -104,7 +104,7 @@
+
+ #define BORDER_X_OFFSET 3
+ #define BORDER_Y_OFFSET 27
+-#define FIRST_CHESS_PROGRAM "fairymax"
++#define FIRST_CHESS_PROGRAM "gnuchess"
+ #define SECOND_CHESS_PROGRAM "fairymax"
+ #define FIRST_DIRECTORY "."
+ #define SECOND_DIRECTORY "."