summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-emulation/gngb/gngb-20060204.ebuild')
-rw-r--r--games-emulation/gngb/gngb-20060204.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/games-emulation/gngb/gngb-20060204.ebuild b/games-emulation/gngb/gngb-20060204.ebuild
new file mode 100644
index 000000000000..fbacf0353a09
--- /dev/null
+++ b/games-emulation/gngb/gngb-20060204.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/gngb/gngb-20060204.ebuild,v 1.1 2006/02/23 01:25:24 mr_bones_ Exp $
+
+inherit eutils games
+
+DESCRIPTION="Gameboy / Gameboy Color emulator"
+HOMEPAGE="http://m.peponas.free.fr/gngb/"
+SRC_URI="http://m.peponas.free.fr/gngb/download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~ppc x86"
+IUSE="opengl"
+
+DEPEND="media-libs/libsdl
+ sys-libs/zlib
+ app-arch/bzip2
+ opengl? ( virtual/opengl )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-gcc34.patch"
+}
+
+src_compile() {
+ egamesconf $(use_with opengl gl) || die
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS ChangeLog NEWS README TODO
+ prepgamesdirs
+}