summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-emulation/grustibus/grustibus-0.43-r4.ebuild')
-rw-r--r--games-emulation/grustibus/grustibus-0.43-r4.ebuild14
1 files changed, 11 insertions, 3 deletions
diff --git a/games-emulation/grustibus/grustibus-0.43-r4.ebuild b/games-emulation/grustibus/grustibus-0.43-r4.ebuild
index fe45829d7631..fe90af1055d7 100644
--- a/games-emulation/grustibus/grustibus-0.43-r4.ebuild
+++ b/games-emulation/grustibus/grustibus-0.43-r4.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/grustibus/grustibus-0.43-r4.ebuild,v 1.4 2004/06/08 06:39:45 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/grustibus/grustibus-0.43-r4.ebuild,v 1.5 2004/06/22 22:49:12 mr_bones_ Exp $
+
+inherit eutils
DESCRIPTION="A GNOME-based front-end for the M.A.M.E. video game emulator"
HOMEPAGE="http://grustibus.sourceforge.net"
@@ -11,10 +13,16 @@ LICENSE="GPL-2"
SLOT="0"
IUSE="nls"
-DEPEND=">=games-emulation/xmame-0.56.1
+DEPEND=">=games-emulation/xmame-0.80.1
>=media-libs/gdk-pixbuf-0.17.0
>=gnome-base/gnome-libs-1.4.1.2"
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch "${FILESDIR}/${PV}-crash.patch"
+}
+
src_compile() {
export CPPFLAGS=$(gdk-pixbuf-config --cflags)
econf $(use_enable nls) || die
@@ -23,5 +31,5 @@ src_compile() {
src_install() {
einstall || die
- dodoc README INSTALL ChangeLog TODO NEWS || die "dodoc failed"
+ dodoc README INSTALL ChangeLog TODO NEWS
}