summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-fps/quake3/quake3-1.31.ebuild')
-rw-r--r--games-fps/quake3/quake3-1.31.ebuild42
1 files changed, 23 insertions, 19 deletions
diff --git a/games-fps/quake3/quake3-1.31.ebuild b/games-fps/quake3/quake3-1.31.ebuild
index 145a8192c152..52209e569784 100644
--- a/games-fps/quake3/quake3-1.31.ebuild
+++ b/games-fps/quake3/quake3-1.31.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/quake3/quake3-1.31.ebuild,v 1.5 2003/10/12 04:36:56 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/quake3/quake3-1.31.ebuild,v 1.6 2003/12/09 21:34:48 vapier Exp $
-inherit eutils games
+inherit games
-DESCRIPTION="Quake III"
+DESCRIPTION="Quake III Arena - 3rd installment of the classic id 3D first-person shooter"
HOMEPAGE="http://www.idsoftware.com/"
SRC_URI="ftp://ftp.idsoftware.com/idstuff/quake3/linux/linuxq3apoint-${PV}.x86.run"
@@ -31,35 +31,39 @@ src_unpack() {
}
src_install() {
- dodir /opt/quake3/
+ local dir=${GAMES_PREFIX_OPT}/${PN}
+ dodir ${dir}
- insinto /opt/quake3/baseq3
+ insinto ${dir}/baseq3
doins baseq3/*.pk3
- insinto /opt/quake3/missionpack
+ mv Docs ${D}/${dir}/
+ insinto ${dir}/missionpack
doins missionpack/*.pk3
+ mv pb ${D}/${dir}/
- exeinto /opt/quake3/
- insinto /opt/quake3/
- doexe bin/x86/{quake3.x86,q3ded} ${FILESDIR}/startq3ded
- doins quake3.xpm README* Q3A_EULA.txt Help/*
- dogamesbin ${FILESDIR}/quake3
+ exeinto ${dir}
+ insinto ${dir}
+ doexe bin/Linux/x86/{quake3.x86,q3ded}
+ doins quake3.xpm README* Q3A_EULA.txt
+ dogamesbin ${FILESDIR}/quake3 ${FILESDIR}/q3ded
- exeinto /etc/init.d
- newexe ${FILESDIR}/q3ded.rc q3ded
+ exeinto /etc/init.d ; newexe ${FILESDIR}/q3ded.rc q3ded
+ insinto /etc/conf.d ; newins ${FILESDIR}/q3ded.conf.d q3ded
+ insinto /usr/share/pixmaps
+ doins quake3.xpm
- prepgamesdirs /opt/quake3
+ prepgamesdirs
+ make_desktop_entry quake3 "Quake III Arena" quake3.xpm
}
pkg_postinst() {
- enewuser q3 -1 /bin/bash /opt/quake3 ${GAMES_GROUP}
+ games_pkg_postinst
- einfo "You need to copy pak0.pk3 from your Quake3 CD into /opt/quake3/baseq3."
+ einfo "You need to copy pak0.pk3 from your Quake3 CD into ${dir}/baseq3."
einfo "Or if you have got a Window installation of Q3 make a symlink to save space."
echo
einfo "To start a dedicated server, run"
einfo "\t/etc/init.d/q3ded start"
echo
- einfo "The dedicated server is started under the q3 user account."
-
- games_pkg_postinst
+ einfo "The dedicated server is started under the ${GAMES_USER_DED} user account."
}