summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-puzzle/xphotohunter/xphotohunter-1.4-r1.ebuild')
-rw-r--r--games-puzzle/xphotohunter/xphotohunter-1.4-r1.ebuild12
1 files changed, 6 insertions, 6 deletions
diff --git a/games-puzzle/xphotohunter/xphotohunter-1.4-r1.ebuild b/games-puzzle/xphotohunter/xphotohunter-1.4-r1.ebuild
index 40eca31aa68f..2b764fbabaac 100644
--- a/games-puzzle/xphotohunter/xphotohunter-1.4-r1.ebuild
+++ b/games-puzzle/xphotohunter/xphotohunter-1.4-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/xphotohunter/xphotohunter-1.4-r1.ebuild,v 1.7 2009/01/03 22:12:11 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/xphotohunter/xphotohunter-1.4-r1.ebuild,v 1.8 2009/01/26 01:19:08 mr_bones_ Exp $
EAPI=2
inherit eutils games toolchain-funcs
@@ -21,12 +21,12 @@ DEPEND="media-libs/imlib[gtk]"
RDEPEND="${DEPEND}
media-sound/esound"
-src_unpack() {
- unpack ${A}
- cd "${S}"
+src_prepare() {
epatch "${FILESDIR}/${P}"-gentoo.patch
- sed -i -e "s:@GENTOO_STATEDIR@:${GAMES_STATEDIR}/${PN}:" \
- handler.c || die "Patching state dir failed"
+ sed -i \
+ -e "s:@GENTOO_STATEDIR@:${GAMES_STATEDIR}/${PN}:" \
+ handler.c \
+ || die "Patching state dir failed"
}
src_compile() {