summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-puzzle/xwelltris')
-rw-r--r--games-puzzle/xwelltris/ChangeLog7
-rw-r--r--games-puzzle/xwelltris/xwelltris-1.0.1.ebuild31
2 files changed, 20 insertions, 18 deletions
diff --git a/games-puzzle/xwelltris/ChangeLog b/games-puzzle/xwelltris/ChangeLog
index ecc0321340a7..cf31196b4134 100644
--- a/games-puzzle/xwelltris/ChangeLog
+++ b/games-puzzle/xwelltris/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-puzzle/xwelltris
-# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/xwelltris/ChangeLog,v 1.13 2008/03/15 04:34:31 mr_bones_ Exp $
+# Copyright 2000-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/xwelltris/ChangeLog,v 1.14 2015/01/06 19:17:09 mr_bones_ Exp $
+
+ 06 Jan 2015; Michael Sterrett <mr_bones_@gentoo.org> xwelltris-1.0.1.ebuild:
+ EAPI=5
15 Mar 2008; Michael Sterrett <mr_bones_@gentoo.org>
xwelltris-1.0.1.ebuild:
diff --git a/games-puzzle/xwelltris/xwelltris-1.0.1.ebuild b/games-puzzle/xwelltris/xwelltris-1.0.1.ebuild
index 868a5d9d454b..cf9b42c10ee7 100644
--- a/games-puzzle/xwelltris/xwelltris-1.0.1.ebuild
+++ b/games-puzzle/xwelltris/xwelltris-1.0.1.ebuild
@@ -1,7 +1,8 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/xwelltris/xwelltris-1.0.1.ebuild,v 1.15 2008/03/15 04:34:31 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/xwelltris/xwelltris-1.0.1.ebuild,v 1.16 2015/01/06 19:17:09 mr_bones_ Exp $
+EAPI=5
inherit games
DESCRIPTION="2.5D tetris like game"
@@ -13,26 +14,25 @@ SLOT="0"
KEYWORDS="amd64 ppc x86"
IUSE=""
-DEPEND="media-libs/libsdl
- media-libs/sdl-image"
+DEPEND="media-libs/libsdl[video]
+ media-libs/sdl-image[gif]"
-src_unpack() {
- unpack ${A}
- cd "${S}"
+src_prepare() {
sed -i \
-e '/INSTALL_PROGRAM/s/-s //' \
- src/Make.common.in \
- || die "sed Make.common.in failed"
+ src/Make.common.in || die
sed -i \
-e "/GLOBAL_SEARCH/s:\".*\":\"${GAMES_DATADIR}/${PN}\":" \
- src/include/globals.h.in \
- || die "sed globals.h.in failed"
+ src/include/globals.h.in || die
}
-src_compile() {
+src_configure() {
# configure/build process is pretty messed up
- egamesconf --with-sdl || die
- emake -C src || die "emake failed"
+ egamesconf --with-sdl
+}
+
+src_compile() {
+ emake -C src
}
src_install() {
@@ -40,8 +40,7 @@ src_install() {
emake install \
INSTDIR="${D}/${GAMES_BINDIR}" \
INSTLIB="${D}/${GAMES_DATADIR}/${PN}" \
- INSTMAN=/usr/share/man \
- || die "emake install failed"
+ INSTMAN=/usr/share/man
dodoc AUTHORS Changelog README*
prepgamesdirs
}