summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-roguelike/scourge/scourge-0.10.1.ebuild')
-rw-r--r--games-roguelike/scourge/scourge-0.10.1.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/games-roguelike/scourge/scourge-0.10.1.ebuild b/games-roguelike/scourge/scourge-0.10.1.ebuild
new file mode 100644
index 000000000000..8301f036b5c0
--- /dev/null
+++ b/games-roguelike/scourge/scourge-0.10.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-roguelike/scourge/scourge-0.10.1.ebuild,v 1.1 2005/07/31 05:32:11 mr_bones_ Exp $
+
+inherit flag-o-matic eutils games
+
+DESCRIPTION="A rogue-like adventure game to eliminate pests"
+HOMEPAGE="http://scourge.sf.net"
+SRC_URI="mirror://sourceforge/scourge/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND="virtual/x11
+ virtual/glu
+ virtual/opengl
+ >=media-libs/freetype-2
+ >=media-libs/libsdl-1.2
+ media-libs/sdl-net
+ media-libs/sdl-mixer"
+
+S=${WORKDIR}/${PN}
+
+src_unpack() {
+ unpack ${A}
+ find "${S}/data" -type f -exec chmod a-x \{\} \;
+ cd "${S}"
+ epatch "${FILESDIR}/${PV}-datadir.patch"
+}
+
+src_compile() {
+ egamesconf \
+ --disable-binreloc \
+ --with-data-dir="${GAMES_DATADIR}/${PN}/data" \
+ || die
+ emake || die "emake failed"
+}
+
+src_install() {
+ dogamesbin src/scourge || die "dogamesbin failed"
+ dodir "${GAMES_DATADIR}/${PN}"
+ cp -r data/ "${D}${GAMES_DATADIR}/${PN}" || die "cp failed"
+ dodoc AUTHORS README || die "dodoc failed"
+ prepgamesdirs
+}