summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-rpg')
-rw-r--r--games-rpg/eternal-lands/ChangeLog8
-rw-r--r--games-rpg/eternal-lands/Manifest2
-rw-r--r--games-rpg/eternal-lands/eternal-lands-1.1.2.ebuild139
-rw-r--r--games-rpg/eternal-lands/files/digest-eternal-lands-1.1.24
4 files changed, 152 insertions, 1 deletions
diff --git a/games-rpg/eternal-lands/ChangeLog b/games-rpg/eternal-lands/ChangeLog
index 69f0eddadf91..f0af2056b8ae 100644
--- a/games-rpg/eternal-lands/ChangeLog
+++ b/games-rpg/eternal-lands/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-rpg/eternal-lands
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-rpg/eternal-lands/ChangeLog,v 1.4 2005/01/28 19:59:14 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-rpg/eternal-lands/ChangeLog,v 1.5 2005/10/24 05:47:43 mr_bones_ Exp $
+
+*eternal-lands-1.1.2 (24 Oct 2005)
+
+ 24 Oct 2005; Michael Sterrett <mr_bones_@gentoo.org>
+ +eternal-lands-1.1.2.ebuild:
+ version bump
*eternal-lands-1.0.1 (28 Jan 2005)
diff --git a/games-rpg/eternal-lands/Manifest b/games-rpg/eternal-lands/Manifest
index 668f113c325e..305321630a2d 100644
--- a/games-rpg/eternal-lands/Manifest
+++ b/games-rpg/eternal-lands/Manifest
@@ -1,4 +1,6 @@
MD5 f14047c98a46008d55322cc6df542db0 metadata.xml 218
+MD5 d7f64c723dc1c2d4af223c96689b3915 eternal-lands-1.1.2.ebuild 4140
MD5 d297a30b0973849e5c91922c61e32f25 ChangeLog 796
MD5 5880576ab7a69d81483583d9bc20fdb9 eternal-lands-1.0.1.ebuild 3971
MD5 cd095b45439a8c74608347887c8eb72a files/digest-eternal-lands-1.0.1 236
+MD5 e6486bdc48faa0017a36591fb674f105 files/digest-eternal-lands-1.1.2 242
diff --git a/games-rpg/eternal-lands/eternal-lands-1.1.2.ebuild b/games-rpg/eternal-lands/eternal-lands-1.1.2.ebuild
new file mode 100644
index 000000000000..0f09da157e61
--- /dev/null
+++ b/games-rpg/eternal-lands/eternal-lands-1.1.2.ebuild
@@ -0,0 +1,139 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-rpg/eternal-lands/eternal-lands-1.1.2.ebuild,v 1.1 2005/10/24 05:47:43 mr_bones_ Exp $
+
+inherit games
+
+MY_PV=${PV%_p*}
+DESCRIPTION="An online MMORPG written in C and SDL"
+HOMEPAGE="http://www.eternal-lands.com"
+SRC_URI="http://el.tfm.ro/el_${MY_PV//.}_linux.zip
+ ftp://ftp.berlios.de/pub/elc/elc_${MY_PV//.}.tgz
+ mapeditor? ( ftp://ftp.berlios.de/pub/elc/mapedit_${MY_PV//.}.tgz )
+ !nomusic? ( http://el.tfm.ro/el_music_101.zip )"
+
+LICENSE="eternal_lands"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc mapeditor nomusic"
+
+RDEPEND="virtual/x11
+ virtual/opengl
+ >=media-libs/libsdl-1.2.5
+ >=media-libs/sdl-net-1.2.5
+ >media-libs/openal-20020127
+ media-libs/libvorbis
+ >=dev-libs/libxml2-2.6.7
+ =media-libs/cal3d-0.10.0
+ >=media-libs/libpng-1.2.8
+ mapeditor? ( >=x11-libs/gtk+-2.4 )"
+
+DEPEND="${RDEPEND}
+ app-arch/unzip
+ doc? ( >=app-doc/doxygen-1.3.8
+ >=media-gfx/graphviz-1.10 )"
+
+src_unpack() {
+ OPTIONS="OPTIONS=-DDATA_DIR="\\\\\"${GAMES_DATADIR}/${PN}/\\\\\"""
+ S_CLIENT="${WORKDIR}/elc"
+ S_MAPEDITOR="${WORKDIR}/map_editor"
+ BROWSER="mozilla"
+
+ unpack ${A}
+ use amd64 && OPTIONS="${OPTIONS} -DX86_64"
+ cd "${S_CLIENT}"
+ sed \
+ -e "s@CFLAGS=\$(PLATFORM) \$(CWARN) -O -ggdb -pipe@CFLAGS=${CFLAGS} @g"\
+ -e "s@CXXFLAGS=\$(PLATFORM) \$(CXXWARN) -O -ggdb -pipe@CXXFLAGS=${CXXFLAGS} @g"\
+ -e "s@OPTIONS=@${OPTIONS} @g" \
+ Makefile.linux > Makefile \
+ || die "sed failed"
+ sed \
+ -e 's/#browser/browser/g' \
+ -e "s/browser = mozilla/#browser = ${BROWSER}/g" \
+ -e "s@#data_dir = /usr/local/games/el/@#data_dir = ${GAMES_DATADIR}/${PN}/@g" \
+ el.ini > ../el.ini \
+ || die "sed failed"
+ if use mapeditor; then
+ cd "${S_MAPEDITOR}"
+ sed \
+ -e "s@CFLAGS=@CFLAGS=${CFLAGS} @g" \
+ -e "s@OPTIONS=@${OPTIONS} @g" \
+ Makefile.linux > Makefile \
+ || die "sed failed"
+ sed \
+ -e "s@#data_dir = /usr/local/games/el/@#data_dir = ${GAMES_DATADIR}/${PN}/@g" \
+ mapedit.ini > ../mapedit.ini \
+ || die "sed failed"
+ mv browser.lst ../browser.lst
+ fi
+ cd "${WORKDIR}"
+ cp license.txt EULA || die "cp failed"
+ cp -r "${S_CLIENT}"/languages .
+}
+
+src_compile() {
+ cd "${S_CLIENT}"
+ emake || die "emake failed"
+ cp el.x86.linux.bin ../el.x86.linux.bin || die "cp failed"
+ if use doc; then
+ emake docs || die "Failed to create documentation, try with USE=-doc"
+ mv ./docs/html/ ../client || die "Failed to move documentation directory"
+ fi
+ if use mapeditor; then
+ cd "${S_MAPEDITOR}"
+ emake || die "emake failed"
+ cp mapedit.x86.linux.bin ../mapedit.x86.linux.bin || die "cp failed"
+ fi
+}
+
+src_install() {
+ cd "${WORKDIR}"
+
+ newgamesbin el.x86.linux.bin el || die "newgamesbin failed"
+ newicon el_icon.png ${PN}.png || die "newicon failed"
+ make_desktop_entry el "Eternal Lands"
+ dodoc EULA
+ insinto "${GAMES_DATADIR}/${PN}"
+ doins -r 2dobjects 3dobjects languages maps particles sound textures tiles \
+ meshes animations actor_defs books skeletons \
+ *.ini entrable.lst harvestable.lst \
+ global_filters.txt e3dlist.txt \
+ || die "doins failed"
+
+ if use mapeditor; then
+ newgamesbin mapedit.x86.linux.bin el-mapedit || die "newgamesbin failed"
+ doins -r browser.lst mapeditor || die "doins failed"
+ dohtml -r "${WORKDIR}/mapeditor" || die
+ make_desktop_entry el-mapedit "Map editor"
+ fi
+ if ! use nomusic ; then
+ doins -r music/ || die "doins failed"
+ fi
+
+ if use doc ; then
+ dohtml -r "${WORKDIR}/client/"*
+ fi
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ echo
+ einfo "To run the game: el"
+ echo
+ if use mapeditor; then
+ einfo "To use the map editor: el-mapedit"
+ einfo "Copy ${GAMES_DATADIR}/${PN}/mapedit.ini to ~/.elc/"
+ einfo "to make per-user changes."
+ echo
+ einfo "To read an introduction to the map editor, read"
+ einfo "/usr/share/doc/${PF}/html/mapeditor.html"
+ echo
+ fi
+ if use doc; then
+ einfo "The documentation for the client source can be found"
+ einfo "in /usr/share/doc/${PF}/html/index.html"
+ echo
+ fi
+}
diff --git a/games-rpg/eternal-lands/files/digest-eternal-lands-1.1.2 b/games-rpg/eternal-lands/files/digest-eternal-lands-1.1.2
new file mode 100644
index 000000000000..ebb5cd5533cd
--- /dev/null
+++ b/games-rpg/eternal-lands/files/digest-eternal-lands-1.1.2
@@ -0,0 +1,4 @@
+MD5 3591dd7dfd4f7a2f35d77f2cd0044610 el_112_linux.zip 28691858
+MD5 a4be2dd8a7ff378e0836ce4d26cedfd0 elc_112.tgz 596932
+MD5 1f87d42843d4deb824d588f7fe3f7432 mapedit_112.tgz 123705
+MD5 16fe9ca8c9f4e3757571bfeeff8e260b el_music_101.zip 27141551