summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-simulation/kfreeflight/kfreeflight-0.2.1_rc1.ebuild')
-rw-r--r--games-simulation/kfreeflight/kfreeflight-0.2.1_rc1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/games-simulation/kfreeflight/kfreeflight-0.2.1_rc1.ebuild b/games-simulation/kfreeflight/kfreeflight-0.2.1_rc1.ebuild
new file mode 100644
index 000000000000..345c4aa05fbc
--- /dev/null
+++ b/games-simulation/kfreeflight/kfreeflight-0.2.1_rc1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/kfreeflight/kfreeflight-0.2.1_rc1.ebuild,v 1.1 2006/10/29 20:23:13 tupone Exp $
+
+inherit eutils kde games
+
+MY_P=${P//_/}
+
+DESCRIPTION="GUI-Frontend for FlightGear"
+HOMEPAGE="http://kfreeflight.sourceforge.net/"
+SRC_URI="mirror://sourceforge/kfreeflight/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+RDEPEND="games-simulation/flightgear"
+
+S=${WORKDIR}/${PN}-${PV%_*}
+
+need-kde 3.5.2
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS NEWS TODO
+
+ rm -rf ${D}/usr/share/applnk
+ make_desktop_entry ${PN}
+
+ prepgamesdirs
+}