summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-simulation')
-rw-r--r--games-simulation/flightgear/ChangeLog5
-rw-r--r--games-simulation/flightgear/flightgear-0.9.10.ebuild6
2 files changed, 8 insertions, 3 deletions
diff --git a/games-simulation/flightgear/ChangeLog b/games-simulation/flightgear/ChangeLog
index d8d32193199c..eb4939cb77b2 100644
--- a/games-simulation/flightgear/ChangeLog
+++ b/games-simulation/flightgear/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-simulation/flightgear
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-simulation/flightgear/ChangeLog,v 1.26 2007/01/12 23:57:50 nyhm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/flightgear/ChangeLog,v 1.27 2007/03/12 19:15:12 nyhm Exp $
+
+ 12 Mar 2007; Tristan Heaven <nyhm@gentoo.org> flightgear-0.9.10.ebuild:
+ Install menu entry, bug #160210
12 Jan 2007; Tristan Heaven <nyhm@gentoo.org> flightgear-0.9.10.ebuild:
Allow sdl to be used instead of glut
diff --git a/games-simulation/flightgear/flightgear-0.9.10.ebuild b/games-simulation/flightgear/flightgear-0.9.10.ebuild
index 6f82ab9a0fbb..4633a054302a 100644
--- a/games-simulation/flightgear/flightgear-0.9.10.ebuild
+++ b/games-simulation/flightgear/flightgear-0.9.10.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-simulation/flightgear/flightgear-0.9.10.ebuild,v 1.3 2007/01/12 23:57:50 nyhm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/flightgear/flightgear-0.9.10.ebuild,v 1.4 2007/03/12 19:15:12 nyhm Exp $
-inherit games
+inherit eutils games
MY_PN=FlightGear
MY_P=${MY_PN}-${PV}
@@ -36,6 +36,8 @@ src_install() {
emake DESTDIR="${D}" install || die "emake install failed"
insinto "${GAMES_DATADIR}"/${MY_PN}
doins -r ../data/* || die "doins failed"
+ newicon ../data/Aircraft/T38/thumbnail.jpg ${PN}.jpg
+ make_desktop_entry fgfs FlightGear /usr/share/pixmaps/${PN}.jpg
dodoc AUTHORS ChangeLog NEWS README Thanks
prepgamesdirs
}