summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'gnome-base/ORBit2/ORBit2-2.10.3.ebuild')
-rw-r--r--gnome-base/ORBit2/ORBit2-2.10.3.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnome-base/ORBit2/ORBit2-2.10.3.ebuild b/gnome-base/ORBit2/ORBit2-2.10.3.ebuild
new file mode 100644
index 000000000000..eadb168172d4
--- /dev/null
+++ b/gnome-base/ORBit2/ORBit2-2.10.3.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/ORBit2/ORBit2-2.10.3.ebuild,v 1.1 2004/07/12 15:27:00 foser Exp $
+
+inherit gnome2 eutils
+
+DESCRIPTION="ORBit2 is a high-performance CORBA ORB"
+HOMEPAGE="http://www.gnome.org/"
+
+IUSE="doc ssl"
+SLOT="0"
+LICENSE="GPL-2 LGPL-2"
+KEYWORDS="~x86 ~ppc ~alpha ~sparc ~hppa ~amd64 ~ia64 ~mips ~ppc64"
+
+RDEPEND=">=dev-libs/glib-2
+ >=dev-libs/popt-1.5
+ >=dev-libs/libIDL-0.7.4
+ dev-util/indent
+ ssl? ( >=dev-libs/openssl-0.9.6 )"
+# FIXME linc is now integrated, but a block isn't necessary
+# and probably complicated FIXME
+
+# FIXME ssl is optional, but not switchable
+
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.14
+ doc? ( >=dev-util/gtk-doc-1 )"
+
+MAKEOPTS="${MAKEOPTS} -j1"
+
+DOCS="AUTHORS ChangeLog COPYING* README* HACKING INSTALL NEWS TODO MAINTAINERS"