summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'gnome-base/libghttp')
-rw-r--r--gnome-base/libghttp/libghttp-1.0.9-r2.ebuild37
-rw-r--r--gnome-base/libghttp/libghttp-1.0.9-r3.ebuild34
-rw-r--r--gnome-base/libghttp/libghttp-1.0.9-r4.ebuild6
3 files changed, 3 insertions, 74 deletions
diff --git a/gnome-base/libghttp/libghttp-1.0.9-r2.ebuild b/gnome-base/libghttp/libghttp-1.0.9-r2.ebuild
deleted file mode 100644
index 42faaf92c5a9..000000000000
--- a/gnome-base/libghttp/libghttp-1.0.9-r2.ebuild
+++ /dev/null
@@ -1,37 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/libghttp/libghttp-1.0.9-r2.ebuild,v 1.17 2006/02/25 01:58:07 allanonjl Exp $
-
-inherit libtool
-
-DESCRIPTION="GNOME http client library"
-SRC_URI="ftp://ftp.gnome.org/pub/GNOME/stable/sources/${PN}/${P}.tar.gz"
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="x86 ppc sparc"
-IUSE=""
-
-HOMEPAGE="http://www.gnome.org/"
-
-DEPEND="virtual/libc"
-
-src_compile() {
- elibtoolize
- ./configure --host=${CHOST} \
- --prefix=/usr \
- --sysconfdir=/etc \
- --localstatedir=/var/lib || die
-
- emake || die
-}
-
-src_install() {
- make prefix=${D}/usr \
- sysconfdir=${D}/etc \
- localstatedir=${D}/var/lib \
- install || die
-
- dodoc AUTHORS COPYING* ChangeLog README NEWS TODO
-
- dohtml doc/*.html
-}
diff --git a/gnome-base/libghttp/libghttp-1.0.9-r3.ebuild b/gnome-base/libghttp/libghttp-1.0.9-r3.ebuild
deleted file mode 100644
index 75a64d999080..000000000000
--- a/gnome-base/libghttp/libghttp-1.0.9-r3.ebuild
+++ /dev/null
@@ -1,34 +0,0 @@
-# Copyright 1999-2004 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/libghttp/libghttp-1.0.9-r3.ebuild,v 1.15 2004/07/11 20:00:14 spider Exp $
-
-GNOME_TARBALL_SUFFIX="gz"
-inherit libtool gnome.org
-
-DESCRIPTION="GNOME http client library"
-LICENSE="LGPL-2 GPL-2"
-SLOT="0"
-KEYWORDS="x86 ppc ~sparc ~alpha hppa amd64"
-IUSE=""
-
-HOMEPAGE="http://www.gnome.org/"
-
-DEPEND="virtual/libc"
-
-src_compile() {
- elibtoolize
-
- econf || die
- emake || die
-}
-
-src_install() {
- einstall || die
-
- # headers needed for Intermezzo (bug 11501)
- insinto /usr/include/ghttp-1.0/
- doins http*.h
-
- dodoc AUTHORS COPYING* ChangeLog README NEWS TODO
- dohtml doc/*.html
-}
diff --git a/gnome-base/libghttp/libghttp-1.0.9-r4.ebuild b/gnome-base/libghttp/libghttp-1.0.9-r4.ebuild
index c3dc8701330c..e2ecbeab79e4 100644
--- a/gnome-base/libghttp/libghttp-1.0.9-r4.ebuild
+++ b/gnome-base/libghttp/libghttp-1.0.9-r4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/libghttp/libghttp-1.0.9-r4.ebuild,v 1.14 2006/10/29 19:38:30 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/libghttp/libghttp-1.0.9-r4.ebuild,v 1.15 2008/03/10 19:05:45 leio Exp $
GNOME_TARBALL_SUFFIX="gz"
inherit libtool gnome.org eutils
@@ -19,9 +19,9 @@ src_unpack() {
unpack ${A}
- cd ${S}
+ cd "${S}"
# fixes http locale related bug (#33386)
- epatch ${FILESDIR}/${P}-fixlocale.patch
+ epatch "${FILESDIR}/${P}-fixlocale.patch"
}