summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'gnome-base/oaf/oaf-0.6.4.ebuild')
-rw-r--r--gnome-base/oaf/oaf-0.6.4.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/gnome-base/oaf/oaf-0.6.4.ebuild b/gnome-base/oaf/oaf-0.6.4.ebuild
new file mode 100644
index 000000000000..70d6b9a3e0b6
--- /dev/null
+++ b/gnome-base/oaf/oaf-0.6.4.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/oaf/oaf-0.6.4.ebuild,v 1.1 2001/03/06 05:21:10 achim Exp $
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="Object Activation Framework for GNOME"
+SRC_URI="ftp://ftp.gnome.org/pub/GNOME/unstable/sources/${PN}/${A}
+ ftp://gnome.eazel.com/pub/gnome/unstable/sources/${PN}/${A}"
+
+DEPEND=">=sys-devel/perl-5
+ >=app-arch/rpm-3.0.6
+ >=gnome-base/ORBit-0.5.7
+ >=gnome-base/libxml-1.8.11
+ nls? ( sys-devel/gettext )"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ cp configure configure.orig
+ sed -e "s:perl5\.00404:perl5.6.0:" configure.orig > configure
+}
+
+src_compile() {
+ local myconf
+ if [ -z "`use nls`" ]
+ then
+ myconf="--disable-nls"
+ fi
+ try ./configure --host=${CHOST} --prefix=/opt/gnome --sysconfdir=/etc/opt/gnome ${myconf}
+ try make
+}
+
+src_install() {
+
+ try make prefix=${D}/opt/gnome sysconfdir=${D}/etc/opt/gnome install
+ dodoc AUTHORS COPYING* ChangeLog README
+ dodoc NEWS TODO
+}
+
+pkg_postinst() {
+ ldconfig -r ${ROOT}
+}
+
+
+