summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'gnustep-apps/gorm')
-rw-r--r--gnustep-apps/gorm/ChangeLog9
-rw-r--r--gnustep-apps/gorm/files/gorm-1.2.12-objc2_support.patch71
-rw-r--r--gnustep-apps/gorm/gorm-1.2.18.ebuild (renamed from gnustep-apps/gorm/gorm-1.2.12.ebuild)11
3 files changed, 13 insertions, 78 deletions
diff --git a/gnustep-apps/gorm/ChangeLog b/gnustep-apps/gorm/ChangeLog
index fee5e9635093..b832726f0275 100644
--- a/gnustep-apps/gorm/ChangeLog
+++ b/gnustep-apps/gorm/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for gnustep-apps/gorm
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnustep-apps/gorm/ChangeLog,v 1.43 2012/04/07 14:54:20 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnustep-apps/gorm/ChangeLog,v 1.44 2012/06/20 08:21:59 voyageur Exp $
+
+*gorm-1.2.18 (20 Jun 2012)
+
+ 20 Jun 2012; Bernard Cafarelli <voyageur@gentoo.org> -gorm-1.2.12.ebuild,
+ -files/gorm-1.2.12-objc2_support.patch, +gorm-1.2.18.ebuild:
+ Version bump, code cleanup, stability fixes and support for newer runtimes.
+ Remove old
07 Apr 2012; Markus Meier <maekke@gentoo.org> gorm-1.2.16.ebuild:
x86 stable, bug #410601
diff --git a/gnustep-apps/gorm/files/gorm-1.2.12-objc2_support.patch b/gnustep-apps/gorm/files/gorm-1.2.12-objc2_support.patch
deleted file mode 100644
index a3a6b6b36926..000000000000
--- a/gnustep-apps/gorm/files/gorm-1.2.12-objc2_support.patch
+++ /dev/null
@@ -1,71 +0,0 @@
---- apps/gorm/trunk/GormCore/GormClassManager.m 2010/09/16 04:57:56 31358
-+++ apps/gorm/trunk/GormCore/GormClassManager.m 2010/09/16 05:04:00 31359
-@@ -690,7 +690,7 @@
- }
-
- actions = [self allActionsForClassNamed: className];
-- while (actions == nil && (theClass = class_get_super_class(theClass)) != nil
-+ while (actions == nil && (theClass = class_getSuperclass(theClass)) != nil
- && theClass != [NSObject class])
- {
- className = NSStringFromClass(theClass);
-@@ -813,7 +813,7 @@
- }
-
- outlets = [self allOutletsForClassNamed: className];
-- while (outlets == nil && (theClass = class_get_super_class(theClass)) != nil
-+ while (outlets == nil && (theClass = class_getSuperclass(theClass)) != nil
- && theClass != [NSObject class])
- {
- className = NSStringFromClass(theClass);
-@@ -885,7 +885,7 @@
-
- if (theClass != nil)
- {
-- theClass = class_get_super_class(theClass);
-+ theClass = class_getSuperclass(theClass);
- if (theClass != nil && theClass != [NSObject class])
- {
- NSString *name;
---- apps/gorm/trunk/GormCore/GormObjectInspector.m 2010/09/16 04:57:56 31358
-+++ apps/gorm/trunk/GormCore/GormObjectInspector.m 2010/09/16 05:04:00 31359
-@@ -223,17 +223,13 @@
-
- while (c != nil && c != [NSObject class])
- {
-- struct objc_method_list *mlist = c->methods;
--
-- while (mlist != 0)
-- {
-- struct objc_method *methods = &mlist->method_list[0];
-- int count = mlist->method_count;
-+ unsigned int count;
-+ Method *methods = class_copyMethodList(c, &count);
- int i;
-
- for (i = 0; i < count; i++)
- {
-- SEL sSel = methods[i].method_name;
-+ SEL sSel = method_getName(methods[i]);
- NSString *set = NSStringFromSelector(sSel);
-
- /*
-@@ -246,7 +242,7 @@
- && [sets containsObject: set] == NO)
- {
- char tmp[[set cStringLength]+1];
-- const char *tInfo = methods[i].method_types;
-+ const char *tInfo = method_getTypeEncoding(methods[i]);
- NSString *type = nil;
- NSString *get;
- SEL gSel;
-@@ -323,8 +319,7 @@
- }
- }
- }
-- mlist = mlist->method_next;
-- }
-+ free(methods);
- c = [c superclass];
- }
- [sets sortUsingSelector: @selector(compare:)];
diff --git a/gnustep-apps/gorm/gorm-1.2.12.ebuild b/gnustep-apps/gorm/gorm-1.2.18.ebuild
index d01b8d00e661..f3b5c537a07e 100644
--- a/gnustep-apps/gorm/gorm-1.2.12.ebuild
+++ b/gnustep-apps/gorm/gorm-1.2.18.ebuild
@@ -1,15 +1,15 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/gnustep-apps/gorm/gorm-1.2.12.ebuild,v 1.4 2011/08/19 09:31:31 voyageur Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnustep-apps/gorm/gorm-1.2.18.ebuild,v 1.1 2012/06/20 08:21:59 voyageur Exp $
-EAPI=3
+EAPI=4
inherit gnustep-2
DESCRIPTION="A clone of the NeXTstep Interface Builder application for GNUstep"
HOMEPAGE="http://www.gnustep.org/experience/Gorm.html"
SRC_URI="ftp://ftp.gnustep.org/pub/gnustep/dev-apps/${P}.tar.gz"
-KEYWORDS="amd64 x86 ~x86-fbsd"
+KEYWORDS="~amd64 ~x86 ~x86-fbsd"
LICENSE="GPL-2"
SLOT="0"
IUSE=""
@@ -18,11 +18,10 @@ DEPEND=">=gnustep-base/gnustep-gui-0.18.0"
RDEPEND="${DEPEND}"
src_prepare() {
- epatch "${FILESDIR}"/${P}-objc2_support.patch
sed -i -e "/DOCUMENT_NAME =.*/a \Gorm_DOC_INSTALL_DIR=Developer/Gorm" \
-e "/DOCUMENT_TEXT_NAME =.*/a \ANNOUNCE_DOC_INSTALL_DIR=Developer/Gorm/ReleaseNotes" \
-e "/DOCUMENT_TEXT_NAME =.*/a \README_DOC_INSTALL_DIR=Developer/Gorm/ReleaseNotes" \
-e "/DOCUMENT_TEXT_NAME =.*/a \NEWS_DOC_INSTALL_DIR=Developer/Gorm/ReleaseNotes" \
-e "/DOCUMENT_TEXT_NAME =.*/a \INSTALL_DOC_INSTALL_DIR=Developer/Gorm/ReleaseNotes" \
- "${S}"/Documentation/GNUmakefile
+ Documentation/GNUmakefile
}