summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-base/artsplugin-mpeglib/artsplugin-mpeglib-3.4.0.ebuild')
-rw-r--r--kde-base/artsplugin-mpeglib/artsplugin-mpeglib-3.4.0.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/kde-base/artsplugin-mpeglib/artsplugin-mpeglib-3.4.0.ebuild b/kde-base/artsplugin-mpeglib/artsplugin-mpeglib-3.4.0.ebuild
new file mode 100644
index 000000000000..63d287550065
--- /dev/null
+++ b/kde-base/artsplugin-mpeglib/artsplugin-mpeglib-3.4.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/artsplugin-mpeglib/artsplugin-mpeglib-3.4.0.ebuild,v 1.1 2005/03/13 21:18:58 danarmak Exp $
+
+KMNAME=kdemultimedia
+KMMODULE=mpeglib_artsplug
+MAXKDEVER=$PV
+KM_DEPRANGE="$PV $MAXKDEVER"
+inherit kde-meta eutils
+
+DESCRIPTION="mpeglib plugin for arts"
+KEYWORDS="~x86"
+IUSE=""
+DEPEND="$(deprange $PV $MAXKDEVER kde-base/mpeglib)"
+OLDDEPEND="~kde-base/mpeglib-$PV"
+KMCOPYLIB="libmpeg mpeglib/lib/"
+KMEXTRACTONLY="mpeglib/"
+
+pkg_setup() {
+ if ! useq arts; then
+ eerror "${PN} needs the USE=\"arts\" enabled and also the kdelibs compiled with the USE=\"arts\" enabled"
+ die
+ fi
+}